0

'AdafruitIO_WiFi' does not name a type
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

'AdafruitIO_WiFi' does not name a type

by Sethi on Sun Dec 02, 2018 11:13 am

I install the adafruit IOs libraries and then I load the adafruitio_08_analog_in. When I try to compile the code it fires 'AdafruitIO_WiFi' does not name a type error.

What can I do?

Sethi
 
Posts: 1
Joined: Thu May 31, 2018 8:13 am

Re: 'AdafruitIO_WiFi' does not name a type

by brubell on Tue Dec 04, 2018 10:54 am

Do you have the three required Arduino libraries installed: Adafruit IO Arduino, Adafruit MQTT, and ArduinoHttpClient?

brubell
 
Posts: 216
Joined: Fri Jul 17, 2015 10:33 pm

Re: 'AdafruitIO_WiFi' does not name a type

by prsveloso on Fri Dec 21, 2018 3:45 pm

Hi,
I´m experiencing the same problem. I have the required Arduino libraries installed.
I´m using Arduino IDE 1.8.8
Can´t see where's the problem.
Any suggestions?
Thanks in advance.


I'm sorry but I was compiling to Arduino Uno.
But, if I change to Huzzah ESP8266 I get another error.
Please see the log.
Attachments
Log.txt
(86.63 KiB) Downloaded 7 times

prsveloso
 
Posts: 2
Joined: Fri Dec 18, 2015 3:08 pm

Re: 'AdafruitIO_WiFi' does not name a type

by prsveloso on Sat Dec 22, 2018 11:22 am

I believe that I've found the problem.
If I downgrade, in Boards Manager, the esp8266 v. 2.5.0-beta2 to v2.4.2 it compiles without any problem.
Hope this helps!

prsveloso
 
Posts: 2
Joined: Fri Dec 18, 2015 3:08 pm

Please be positive and constructive with your questions and comments.