0

Nr of feeds not corresponding with triggered webhook message
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Nr of feeds not corresponding with triggered webhook message

by frankortict on Tue May 28, 2019 3:47 am

Goodmoring,

I am using the Adafruit IO platform to retrieve output values from an Aduino and send them to my OutSystems application via webhook messages. However, I noticed that if I create multiple feeds after each other, the trigger function is not sending the corresponding feeds to my application.

In the example (attached) 6 feeds were created, but only 4 feeds were processed by a trigger. I also, confirmed this discrepancy when looking to the trigger log in Adafruit, only 4 triggrers were created.
Adafruit_Feed_log.JPG
Feeds that were send (more than received)
Adafruit_Feed_log.JPG (57.7 KiB) Viewed 90 times
Adafruit_Trigger settings.JPG
Trigger settings
Adafruit_Trigger settings.JPG (23.17 KiB) Viewed 90 times
AdaFruit_Outsystems log.jpg
Received messages in own application
AdaFruit_Outsystems log.jpg (930.94 KiB) Viewed 90 times


I used the "add data" button of the platform, an Aduino simulator and my Aduino to create feeds that needed to be triggered. All resulted in the same behavior.

Can someone explain to me why not all the feeds are triggered by the platform?
This is really important, because in my use case I cannot afford missing feeds!

Thanks in advance!

frankortict
 
Posts: 3
Joined: Fri May 10, 2019 4:55 am

Re: Nr of feeds not corresponding with triggered webhook mes

by frankortict on Fri Jun 07, 2019 5:17 am

I still do not have a solution yet! Can somebody help me?

frankortict
 
Posts: 3
Joined: Fri May 10, 2019 4:55 am

Re: Nr of feeds not corresponding with triggered webhook mes

by brubell on Fri Jun 07, 2019 10:25 am

Can someone explain to me why not all the feeds are triggered by the platform?
This is really important, because in my use case I cannot afford missing feeds!


Is the trigger consistently missing values above, or at, your trigger value? Do you know what values the webhook is receiving (your screenshot doesn't explicitly show the values, might be helpful to debug)?

brubell
 
Posts: 402
Joined: Fri Jul 17, 2015 10:33 pm

Re: Nr of feeds not corresponding with triggered webhook mes

by frankortict on Wed Jun 12, 2019 3:09 am

Thanks for your response!

The trigger is indeed consistently missing feed values. As can be observed from the screenshot below, the webhook was missing the values 2 (2019/05/27 11:16:38am) and 4 (2019/05/27 11:16:49am).
Adafruit_Feed_log.JPG
Adafruit_Feed_log.JPG (57.7 KiB) Viewed 31 times
AdaFruit_Outsystems loglist.jpg
AdaFruit_Outsystems loglist.jpg (22.97 KiB) Viewed 31 times


If I follow the "Run count" of the corresponding trigger, these two values are missing as well. I have the feeling that the platform is not sending all the feeds to the trigger. Could it be the reason that the feeds were created too fast?

Note! The receiving application has a server in a timezone with a 2 hour difference, however the values are matching.

frankortict
 
Posts: 3
Joined: Fri May 10, 2019 4:55 am

Please be positive and constructive with your questions and comments.