0

Timestamp Overflow Error While Generating JWT
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

Timestamp Overflow Error While Generating JWT

by laikathesobaka on Sun Sep 15, 2019 6:03 pm

Hello,

I'm going through the PyPortal Iot Plant Monitor With Google Cloud IoT Core and Circuit Python guide by Brent Rubell (https://learn.adafruit.com/pyportal-iot ... n/overview).

When running the code.py file from CIRCUITPY drive, the PyPortal device successfully connects to WiFi, loads the graphics, but while generating the JWT throws the following error:
"OverflowError: timestamp out of range for platform time_t" (output with traceback from mu-editor attached).

I've replicated the code.py file from the guide as is (https://learn.adafruit.com/pyportal-iot ... code-setup).
Originally I was using Adafruit CircuitPython Bundle V4, and tried replacing the lib directory on the CIRCUITPY drive with the lib from V5 Bundle.
1/5 times when I do this the JWT is successfully generated, not sure if there's a relation.

In case it's relevant my secret.py file looks as follows:

Code: Select all | TOGGLE FULL SIZE
secrets = {
    'ssid' : "MY_NETWORK",             # Keep the two '' quotes around the name
    'password' : "MY_NETWORK_PASSWORD",         # Keep the two '' quotes around password
    'timezone' : "America/Los_Angeles",
    'aio_username' : 'MY_ADAFRUIT_USERNAME',
    'aio_key' : 'MY_ADAFRUIT_KEY',
    'project_id' : 'MY_PROJECT_ID',
    'cloud_region' : 'us-central1',
    'registry_id' : 'MY_REGISTRY_ID',
    'device_id' : 'MY_DEVICE_ID',
    'private_key' : (MY_PRIVATE_KEY)
}



Any help would be greatly appreciated!
Attachments
Screen Shot 2019-09-15 at 2.44.30 PM.png
Screen Shot 2019-09-15 at 2.44.30 PM.png (109.86 KiB) Viewed 87 times

laikathesobaka
 
Posts: 1
Joined: Sat Sep 14, 2019 5:43 pm

Re: Timestamp Overflow Error While Generating JWT

by brubell on Mon Sep 16, 2019 9:17 am

Hi laikathesobaka,

This issue was resolved in the latest release of the ESP32SPI library:

https://github.com/adafruit/Adafruit_Ci ... /tag/1.9.3

brubell
 
Posts: 732
Joined: Fri Jul 17, 2015 10:33 pm

Please be positive and constructive with your questions and comments.