0

Line Charts not displaying data after 9/22/19
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Line Charts not displaying data after 9/22/19

by gadgeteer on Fri Sep 27, 2019 12:43 pm

Hi, I have 2 dashboard line charts (2 different feeds) that do not display data past 9/22/19 when using the 7 and 30 day history settings. (Today is 9/27). The other history settings show current data. When I checked out the corresponding feed pages, everything looks OK, data is up-to-date and normal-looking. The charts on the feed pages are truncated at 9/22. Deleting and replacing the dashboard graphs didn't help. Turning off a feed history and turning it back on deleted the history data in the log, but not the history data for the associated charts on both dashboard and feed pages. No change in the charts. Is there a way to clear the chart data? Note: Other feed and dashboard line graphs are OK, displaying up-to-date. I have read an AIO forum post from a while back about a similar problem which was caused by an internal programming error. Is there something going on?

gadgeteer
 
Posts: 12
Joined: Wed Oct 24, 2012 10:50 am

Re: Line Charts not displaying data after 9/22/19

by abachman on Mon Sep 30, 2019 12:02 pm

Hi gadgeteer,


We're not experiencing any errors on the platform right now that would cause this. The previous issue also caused the "lost chart data" error for everyone on every feed in the same way, so you'd notice it kind of all over.

I want to make sure I understand the scenario: you have a dashboard line chart showing a feed. If you set the "Show History" property in the block editor to "2 days", you see data for the last 2 days (Sept 28 - Sept 30 right now), but if you set it to "30 days", you see data from Aug 23 to Sept 22. Is that right?

Aside: changing the history setting for the feed doesn't delete any data in the feed, it prevents data from being stored in the future. It also changes the way IO represents data for the feed. If a feed is set to "no history" IO doesn't check if it used to have history, it just assumes it doesn't. If the feed is set to store history, it always checks for stored data.


- adam b.

abachman
 
Posts: 338
Joined: Mon Feb 01, 2010 12:48 pm

Re: Line Charts not displaying data after 9/22/19

by gadgeteer on Mon Sep 30, 2019 4:09 pm

Hi, Adam, Thanks for the response. You have it correctly. I checked it again today (9/30) and nothing has changed. For 30-day history, the chart ends at 3:00 PM EST 9/22. 7-day history is blank. 2-day and shorter histories display correctly. Is there any way to reset or purge the chart data? Thanks!

gadgeteer
 
Posts: 12
Joined: Wed Oct 24, 2012 10:50 am

Please be positive and constructive with your questions and comments.