Black Lives Matter - Action and Equality.
0

Having trouble connecting to Adafruit IO?
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

Having trouble connecting to Adafruit IO?

by brubell on Mon Oct 14, 2019 10:24 am

We recently added IP address-based, 24 hour MQTT bans for connections generating more than 500 errors per hour. We're also tracking MQTT subscription and publishing errors more closely. It's possible you had an MQTT client running with either bad MQTT protocol support (e.g., generating invalid packets) or trying repeatedly to subscribe or publish to topics you don't have access to. That often comes from running MQTT code from another project on Adafruit IO. It is also possible that someone on the same network was causing errors that resulted in an IP address block.

brubell
 
Posts: 891
Joined: Fri Jul 17, 2015 10:33 pm

Re: Having trouble connecting to Adafruit IO?

by brubell on Mon Nov 11, 2019 10:42 am

doruku wrote:I am able to send limited amount of characters (around 90) from Bluefruit LE Connect App, even though I have moved from Flora to Circuit Playground Express. Can it be related with this?

Possibly but unlikely - this is most likely related to a limit in the BTLE connect app.

brubell
 
Posts: 891
Joined: Fri Jul 17, 2015 10:33 pm

Re: Having trouble connecting to Adafruit IO?

by lindamartin0589 on Wed May 13, 2020 5:57 am

doruku wrote:I am able to send limited amount of characters (around 90) from Bluefruit LE Connect App here, even though I have moved from Flora to Circuit Playground Express. Can it be related with this?

facing the same problem, please help!

lindamartin0589
 
Posts: 1
Joined: Tue May 12, 2020 5:26 am

Re: Having trouble connecting to Adafruit IO?

by brubell on Fri May 15, 2020 9:55 am

lindamartin0589 wrote:
doruku wrote:I am able to send limited amount of characters (around 90) from Bluefruit LE Connect App [url=/]here[/url], even though I have moved from Flora to Circuit Playground Express. Can it be related with this?

facing the same problem, please help!


This seems to be a limitation with the Bluefruit LE connect app, not adafruit io. Could you send less characters to IO, or separate data into two different feeds?

brubell
 
Posts: 891
Joined: Fri Jul 17, 2015 10:33 pm

Re: Having trouble connecting to Adafruit IO?

by Flanagan20 on Wed May 20, 2020 8:13 am

Yeah. Have been facing this issue. So much fed up now. No where the reliable solution is available

Flanagan20
 
Posts: 1
Joined: Wed May 20, 2020 8:11 am

Re: Having trouble connecting to Adafruit IO?

by cbfraser on Thu May 28, 2020 1:41 pm

a client that was working now on startup cycles through connect/subscribe/disconnect for about 17 iterations and then fails with the connect with error code 6. Where can I find the error codes and thus work out a recovery. And is it possible to find why the disconnect happens, because that triggers the multiple reconnects and subscriptions that eventually cause the code 6 rejection. The monitor page shows the connect/disconnect sequence but no errors.

cbfraser
 
Posts: 8
Joined: Sun Apr 05, 2020 8:16 pm

Re: Having trouble connecting to Adafruit IO?

by brubell on Fri May 29, 2020 10:14 am

cbfraser wrote:a client that was working now on startup cycles through connect/subscribe/disconnect for about 17 iterations and then fails with the connect with error code 6. Where can I find the error codes and thus work out a recovery. And is it possible to find why the disconnect happens, because that triggers the multiple reconnects and subscriptions that eventually cause the code 6 rejection. The monitor page shows the connect/disconnect sequence but no errors.


Hi CBfraser, could you create a new thread for this issue?

brubell
 
Posts: 891
Joined: Fri Jul 17, 2015 10:33 pm

Please be positive and constructive with your questions and comments.