0

IO UI Updated - feedback and issues
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

Re: IO UI Updated - feedback and issues

by brubell on Wed Nov 11, 2020 5:43 pm

I have a feature request - could you add a search bar on the Dashboards page, just like the one on the feeds page?

brubell
 
Posts: 1514
Joined: Fri Jul 17, 2015 10:33 pm

Re: IO UI Updated - feedback and issues

by simpletonite on Wed Nov 11, 2020 6:49 pm

jwcooper wrote:
travswim wrote:There seems to be display issues when you open the navigation menu on mobile (3 line hamburger icon top left), the menu options do not display. I believe it should be: Profile, Feeds, Dashboards, Triggers, Services, My Key. See attachments: https://photos.app.goo.gl/a8X6TXvPaPBRHx3t7

Otherwise the desktop experience is great so far, no issues


This is now fixed. Thank you for bringing it to our attention!


Glad it helped. Also, when at the adafruit.com home page, the Adafruit IO tab is missing at the top for mobile. It is visible for desktop. See attachments: https://photos.app.goo.gl/6RL7ow5GMbPu8s6x8

simpletonite
 
Posts: 3
Joined: Sat Sep 26, 2020 5:52 pm

Re: IO UI Updated - feedback and issues

by klif on Wed Nov 11, 2020 7:16 pm

Perhaps it is nostalgia now, but I was pretty used to the old look. I guess I don't have that much of an issue with the graphical changes, but I'm not a fan of the new colors. To me the green looks a bit too yellow at first glance. A couple of times I've kind of gotten a jolt when I thought my gauge had turned yellow when it was just the new green. I agree with another comment made before me that if the colors are going to be changing perhaps they could be user editable. That would certainly address my color concerns.
Last edited by klif on Wed Nov 11, 2020 7:38 pm, edited 1 time in total.

klif
 
Posts: 5
Joined: Thu Mar 12, 2020 7:26 pm

Re: IO UI Updated - feedback and issues

by cjdshaw on Wed Nov 11, 2020 7:21 pm

- On my desktop, the little trolley icon in the top right shows 0 items. On my mobile, it shows 7, despite it actually being empty. I can reproduce this on the desktop just by making the window narrower until it switches to the mobile layout

- In a maximised window on the desktop (Safari or Chrome), black bars are visible on left and right of the dashboard to keep it symmetrical. If I switch to full screen, it shifts to the left with a big bar on the right, which isn't ideal. If I press Esc to go back to window mode, the layout is completely screwed, with stretched graphs and the bottom controls (Get Help, Learn, Twitter, Facebook etc) overlaid on the dashboard. I have to refresh or change zoom to force a redraw

cjdshaw
 
Posts: 58
Joined: Mon May 08, 2017 4:04 pm

Re: IO UI Updated - feedback and issues

by jdoscher on Wed Nov 11, 2020 7:33 pm

Please widen the canvas even wider than "large" to allow true widescreen and possibly ultrawide displays.

jdoscher
 
Posts: 124
Joined: Tue Jul 22, 2008 12:36 pm

Re: IO UI Updated - feedback and issues

by geoff_g on Wed Nov 11, 2020 8:02 pm

The dashboard is clipped on right side on a iphone7 max so the last hour is not visible
An option to change colour would be good as well

geoff_g
 
Posts: 1
Joined: Mon Aug 31, 2020 1:29 am

Re: IO UI Updated - feedback and issues

by cjdshaw on Wed Nov 11, 2020 8:07 pm

jwcooper wrote:
cjdshaw wrote:When clicking "Settings" on an public dashboard, the settings seem to appear behind the blocks so aren't adjustable


I'm not able to reproduce this issue. What browser are you using?


This occurs on Chrome or Safari on Mac OSX. Try this sample dashboard
https://io.adafruit.com/cjdshaw/dashboards/test

Creating that dashboard made the feed public for you, by the way, but it still has the lock symbol in the Feeds list. If I look at its properties, it's definitely public. Dangerous. If I edit its Privacy, even without doing anything, that makes the padlock symbol go away
Screenshot 2020-11-12 at 00.00.58.png
Screenshot 2020-11-12 at 00.00.58.png (20.11 KiB) Viewed 31 times

cjdshaw
 
Posts: 58
Joined: Mon May 08, 2017 4:04 pm

Re: IO UI Updated - feedback and issues

by trevorshannon on Wed Nov 11, 2020 8:23 pm

Thanks for all the hard work on IO, it is such a great service. Even the free version is so useful! Here's some feedback about the new UI (just my own experiences, take from it what you will!):

1. The rounded ends of the gauge widgets seem a little "web 2.0" aka old fashioned, but that's just me. More importantly, it's difficult to judge where exactly the gauge is indicating when the filled-in section has a rounded endcap--do you read off the centerpoint of the rounded endcap or the edge of the endcap? I know that the gauge is meant to be read off the centerpoint, but a sharp line could probably be more precise. For example, the value below is under the warning limit of 6 despite actually shading in past the 6 tick mark.

Screen Shot 2020-11-11 at 3.55.14 PM.png
Screen Shot 2020-11-11 at 3.55.14 PM.png (76.63 KiB) Viewed 31 times


2. Visible in the screenshot above, the configuration tool for a gauge widget shows a square endcap instead of rounded on the rightmost grey edge.

3. Also related to the gauge widget, there is no longer a difference in color between a gauge that has surpassed the warning value and a gauge that has surpassed the maximum value. I believe it used to go from blue (normal) to yellow (warning) to red (out of bounds). That tristate color setup was great! It would be nice to see that come back.

4. In light mode, the gridlines of the charts show up as black and are very apparent. It is difficult to read the traces on the chart because the grids are such high contrast. Maybe a lower contrast grey a la the dark mode charts?

Screen Shot 2020-11-11 at 4.05.35 PM.png
Screen Shot 2020-11-11 at 4.05.35 PM.png (68.11 KiB) Viewed 31 times


5. In light mode, the stream widget seems to still display white text despite having a white background. The text is visible only when highlighting it as shown in the below screenshot.

Screen Shot 2020-11-11 at 4.06.59 PM.png
Screen Shot 2020-11-11 at 4.06.59 PM.png (79.64 KiB) Viewed 31 times


6. When adding a new block, all the block preview images show the old UI.

Keep up the hard work! (I agree with some others that the blue-on-black was a bit prettier the green-on-black, but I understand the high contrast requirement)

trevorshannon
 
Posts: 3
Joined: Wed Nov 11, 2020 11:42 am

Re: IO UI Updated - feedback and issues

by cjdshaw on Wed Nov 11, 2020 8:44 pm

As you make a desktop window narrower, there's an intermediate point where both the desktop menu and the mobile menu are shown. Also this shows my 0 items / 7 items in trolley issue
Screenshot 2020-11-12 at 00.32.03.png
Screenshot 2020-11-12 at 00.32.03.png (53.88 KiB) Viewed 31 times

cjdshaw
 
Posts: 58
Joined: Mon May 08, 2017 4:04 pm

Re: IO UI Updated - feedback and issues

by chrispynz4 on Wed Nov 11, 2020 9:23 pm

Disappointed that there's been an update which did not fix the map hours of history bug.

chrispynz4
 
Posts: 2
Joined: Thu Feb 27, 2020 2:49 am

Re: IO UI Updated - feedback and issues

by rufusputnam on Thu Nov 12, 2020 2:44 am

Seriously?

OK, first the observations....Text overlaps text. Text overlaps borders. Text overlaps icons. Text bumps up against graphics with no esthetic spacing. Shapes no longer crisp, now big rounded edges reminiscent of pre-school toys. Bizarre color scheme.

On the plus side, it's still functional, if no longer very pleasant to look at...

Here are a couple of examples of what I'm talking about:

https://ibb.co/GV9kVvr
https://ibb.co/tc7G2n3

Image
Image

rufusputnam
 
Posts: 1
Joined: Tue Sep 24, 2019 10:10 pm

Re: IO UI Updated - feedback and issues

by lopatoid on Thu Nov 12, 2020 9:19 am

In my dashboard 1-hour and 24-hours spans in line chart are mixed up. See attachments.
Attachments
Screenshot_2020-11-12_16-07-54.png
Screenshot_2020-11-12_16-07-54.png (69.87 KiB) Viewed 30 times

lopatoid
 
Posts: 1
Joined: Thu Nov 12, 2020 9:15 am

Re: IO UI Updated - feedback and issues

by brubell on Thu Nov 12, 2020 10:49 am

chrispynz4 wrote:Disappointed that there's been an update which did not fix the map hours of history bug.

Could you explain this bug in detail, or link to this bug? I'll file an issue for it. Thanks!

brubell
 
Posts: 1514
Joined: Fri Jul 17, 2015 10:33 pm

Re: IO UI Updated - feedback and issues

by brubell on Thu Nov 12, 2020 10:51 am

rufusputnam wrote:Seriously?

OK, first the observations....Text overlaps text. Text overlaps borders. Text overlaps icons. Text bumps up against graphics with no esthetic spacing. Shapes no longer crisp, now big rounded edges reminiscent of pre-school toys. Bizarre color scheme.

On the plus side, it's still functional, if no longer very pleasant to look at...

Here are a couple of examples of what I'm talking about:

https://ibb.co/GV9kVvr
https://ibb.co/tc7G2n3

Image
Image

The last two images are broken, could you please re-link/re-upload them?

brubell
 
Posts: 1514
Joined: Fri Jul 17, 2015 10:33 pm

Re: IO UI Updated - feedback and issues

by rlucero on Thu Nov 12, 2020 1:06 pm

Changing the time scale for a graph forces the user to move it before the change can be finalized. This will disrupt layouts by forcing other elements to scatter when the graph moves.

rlucero
 
Posts: 1
Joined: Wed Feb 20, 2019 2:37 pm

Please be positive and constructive with your questions and comments.