🎁📬❄️📦 Holiday Shipping Deadlines are approaching! International customers and domestic ground - get your orders in 12/9/2020 📦❄️📬🎁
0

IO UI Updated - feedback and issues
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

Re: IO UI Updated - feedback and issues

by onebeartoe on Fri Nov 13, 2020 11:44 am

cjdshaw wrote:
onebeartoe wrote:Also is there a way to turn on 'dark mode'?


Dark mode is an option under the setting menu - the gear icon in the top right



Thanks! I see the 'Dark Mode' toggle for an individual Dashboard.

Is there dark mode for individual Feeds?

onebeartoe
 
Posts: 83
Joined: Wed Mar 20, 2013 2:58 pm

Re: IO UI Updated - feedback and issues

by jwcooper on Fri Nov 13, 2020 12:28 pm

onebeartoe wrote:
cjdshaw wrote:
onebeartoe wrote:Also is there a way to turn on 'dark mode'?


Dark mode is an option under the setting menu - the gear icon in the top right



Thanks! I see the 'Dark Mode' toggle for an individual Dashboard.

Is there dark mode for individual Feeds?


A global dark mode is something we'd like to implement and is on our roadmap.

jwcooper
 
Posts: 732
Joined: Tue May 01, 2012 9:08 pm

Re: IO UI Updated - feedback and issues

by jimk123 on Fri Nov 13, 2020 2:56 pm

I prefer the previous color scheme, there was much more contrast on line graphs. Perhaps offer a ‘classic’ view with the previous colors or as someone suggested let us pick a color code for each feed on a line graph for complete control. Adafruit IO overall is an amazing product offering and I have been very pleased with it over the years.

jimk123
 
Posts: 219
Joined: Sun Dec 26, 2010 7:04 pm

Re: IO UI Updated - feedback and issues

by Weather411 on Fri Nov 13, 2020 6:08 pm

Great to see all the feedback and quick responses from Adafruit staff. Overall I like the changes but will take a bit of getting used to (like everything else tech)!

Only thing I can't find (or figure out) is a way to delete a group. Go into "Group Settings" and it's not there. Click on the group name and then the small square box next to the individual feeds and a sub-menu comes up: "Graph Feeds", "Remove Feeds", "Disable Feeds" and "Delete Feeds" ...but nothing about deleting the entire group.

Appreciate this issue getting addressed, thank you!

Weather411
 
Posts: 11
Joined: Fri Sep 15, 2017 7:38 pm

Re: IO UI Updated - feedback and issues

by jwcooper on Sat Nov 14, 2020 1:14 pm

Weather411 wrote:Great to see all the feedback and quick responses from Adafruit staff. Overall I like the changes but will take a bit of getting used to (like everything else tech)!

Only thing I can't find (or figure out) is a way to delete a group. Go into "Group Settings" and it's not there. Click on the group name and then the small square box next to the individual feeds and a sub-menu comes up: "Graph Feeds", "Remove Feeds", "Disable Feeds" and "Delete Feeds" ...but nothing about deleting the entire group.

Appreciate this issue getting addressed, thank you!


Yea, this is indeed an issue that we've also found! We'll have an update for this on Monday or Tuesday. Thanks for letting us know. Honestly, I'm not sure if the previous UI had the ability to delete groups, but it must have had it.

In the meantime, you can use the API via curl or whatever language you prefer to delete a group:
https://io.adafruit.com/api/docs/#delete-group

jwcooper
 
Posts: 732
Joined: Tue May 01, 2012 9:08 pm

Re: IO UI Updated - feedback and issues

by biggles4808 on Sat Nov 14, 2020 2:30 pm

New UI bug when filtering data. From the raw data page of my dashboard feed, I tried to filter the results to the last 7 days and when I hit apply filter the screen just went black and stayed that way. Refreshing the page took me back to the data as it was unfiltered.

Cheers

David

biggles4808
 
Posts: 17
Joined: Tue Aug 15, 2017 12:20 pm

Re: IO UI Updated - feedback and issues

by Weather411 on Sat Nov 14, 2020 3:13 pm

jwcooper wrote:In the meantime, you can use the API via curl or whatever language you prefer to delete a group:
https://io.adafruit.com/api/docs/#delete-group


Yep I literally did that last night! A GUI option is nice to have though when already on the website via browser/tablet/phone - thank you!

Weather411
 
Posts: 11
Joined: Fri Sep 15, 2017 7:38 pm

Re: IO UI Updated - feedback and issues

by casaPragelato on Sat Nov 14, 2020 7:10 pm

feed not log decimal

casaPragelato
 
Posts: 2
Joined: Thu Oct 29, 2020 3:21 pm

Re: IO UI Updated - feedback and issues

by macewmi on Mon Nov 16, 2020 10:25 am

Screen Shot 2020-11-16 at 8.20.32 AM.png
Corrupt Gauge Display
Screen Shot 2020-11-16 at 8.20.32 AM.png (63.24 KiB) Viewed 1324 times


If the gauge gets an update while the browser is scrolling the web page, there may be corruption artifacts left behind. That corruption is persistent until the web page is refreshed.

macewmi
 
Posts: 14
Joined: Sat Feb 08, 2020 10:26 am

Re: IO UI Updated - feedback and issues

by macewmi on Mon Nov 16, 2020 10:53 am

The line chart colors change between light and dark modes. I think they should be the same -- adjusted for proper contrast.

Screen Shot 2020-11-16 at 8.50.00 AM.png
Light
Screen Shot 2020-11-16 at 8.50.00 AM.png (40.12 KiB) Viewed 1323 times
Screen Shot 2020-11-16 at 8.49.51 AM.png
Dark
Screen Shot 2020-11-16 at 8.49.51 AM.png (40.66 KiB) Viewed 1323 times

macewmi
 
Posts: 14
Joined: Sat Feb 08, 2020 10:26 am

Re: IO UI Updated - feedback and issues

by macewmi on Mon Nov 16, 2020 11:10 am

When creating a stream block with multiple feeds, can you create an option to color code the different feeds?

macewmi
 
Posts: 14
Joined: Sat Feb 08, 2020 10:26 am

Re: IO UI Updated - feedback and issues

by macewmi on Mon Nov 16, 2020 11:26 am

In light mode, the ticker tape(?) showing feed activity lacks adequate contrast in light mode. The tiny screenshot that's scaled large doesn't display the problem adequately. But in full screen, the bright white page drowns out the grey in ticker tape.

Screen Shot 2020-11-16 at 9.17.17 AM.png
Insufficient contrast in "ticker tape"(?)
Screen Shot 2020-11-16 at 9.17.17 AM.png (8.7 KiB) Viewed 1322 times


p.s. I was just on a dashboard that clearly showed the left hand side (50%+/-) of the ticker tape as RED, then a long stretch of BLUE (indicating how long I'd been on that dashboard?), and then GREY blips. Before I could grab a screen shot, the RED changed to BLUE. I swear I saw this, but I haven't been able to recreate it.

macewmi
 
Posts: 14
Joined: Sat Feb 08, 2020 10:26 am

Re: IO UI Updated - feedback and issues

by jwcooper on Tue Nov 17, 2020 1:06 pm

Latest fixes and features deployed:

    fix date filtering on individual feed page
    add search to dashboards index page, clean up the search input styles
    add ability to delete groups on show group page
    clean up padding on mobile dashboards and kiosk mode
    add ability to add a new feed to multiple groups on creation from top new feed button

jwcooper
 
Posts: 732
Joined: Tue May 01, 2012 9:08 pm

Re: IO UI Updated - feedback and issues

by biggles4808 on Tue Nov 17, 2020 2:32 pm

Not sure if the latest version is live yet but the date filtering on individual data feeds is still not working. Black screen when apply filters is clicked. Trying to just filter for the last 7 days

biggles4808
 
Posts: 17
Joined: Tue Aug 15, 2017 12:20 pm

Re: IO UI Updated - feedback and issues

by cjdshaw on Tue Nov 17, 2020 3:10 pm

jwcooper wrote:Latest fixes and features deployed:
    clean up padding on mobile dashboards and kiosk mode


Looks great, thanks. Make it look much cleaner when I launch it from iPhpne home screen. You could even add the
meta name="apple-mobile-web-app-capable" content="yes"
tag to get it full screen in kiosk mode!

cjdshaw
 
Posts: 55
Joined: Mon May 08, 2017 4:04 pm

Please be positive and constructive with your questions and comments.