🎁📬❄️📦 Holiday Shipping Deadlines are approaching! International customers and domestic ground - get your orders in 12/9/2020 📦❄️📬🎁
0

IO UI Updated - feedback and issues
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

Re: IO UI Updated - feedback and issues

by ArdLab on Fri Nov 20, 2020 6:08 pm

i fixed the link

ArdLab
 
Posts: 4
Joined: Sat Jan 23, 2016 3:14 pm

Re: IO UI Updated - feedback and issues

by Barry99 on Sat Nov 21, 2020 11:36 am

Hi. This "update" really doesn't help. The colours you've chosen may be OK to you but if your red/green colourblind like me, and one in every hundred males are the same, then it definitely doesn't help. Please either revert to the original colours or give us the choice of colour.

Barry99
 
Posts: 1
Joined: Sun Aug 02, 2020 7:13 am

Re: IO UI Updated - feedback and issues

by sahillyard on Sat Nov 21, 2020 3:19 pm

cjdshaw wrote:
sahillyard wrote:You might want to reconsider the font used in the floating text boxes used with the graphs. The dark blue font that contains the data on a black background is difficult to read.
Thanks

Do you mean in light (non-dark) mode? The dark mode floating boxes are easy to read for me, but the issue is more that in light mode, the floating box bg is still dark, making lots of the text hard to read, particularly the purple one
Screenshot 2020-11-20 at 19.36.20.png


Yes, your screenshot shows the problem.

sahillyard
 
Posts: 7
Joined: Fri Dec 08, 2017 10:25 pm

Re: IO UI Updated - feedback and issues

by pmezey on Sun Nov 22, 2020 1:01 pm

On a small screen (e.g. iPhone), the single feed data details clips one of the two most important columns: "Created At". I have to rotate the phone to see more and it still clips part of the timestamp. It seems the Location column is taking an enormous amount of space. I'm sure that is important to some use cases, but I would argue that Timestamp and Value are the two most important. The timestamp is hugely important to understand if your system is still functioning as expected.
IMG_7737 (1).jpeg
IMG_7737 (1).jpeg (73.04 KiB) Viewed 63 times

pmezey
 
Posts: 25
Joined: Tue May 30, 2017 9:56 pm

Re: IO UI Updated - feedback and issues

by cjdshaw on Mon Nov 23, 2020 1:57 pm

ArdLab wrote:Image
Iphone XR iOS13.3.1

Sounds like the same issue people are having in this thread
viewtopic.php?f=56&t=170879

That looks like Chrome for iOS, by the way. What version is it? Have you tried updating the app, or trying on Safari?

cjdshaw
 
Posts: 55
Joined: Mon May 08, 2017 4:04 pm

Re: IO UI Updated - feedback and issues

by jwcooper on Tue Nov 24, 2020 12:01 pm

Barry99 wrote:Hi. This "update" really doesn't help. The colours you've chosen may be OK to you but if your red/green colourblind like me, and one in every hundred males are the same, then it definitely doesn't help. Please either revert to the original colours or give us the choice of colour.


We are looking at the red/green color combinations, thank you for your feedback.

We are not reverting colors, but would like to give the choice of colors in the future.

Also, can you try light mode on the dashboard? That should have better color combinations until we can fix this.

jwcooper
 
Posts: 732
Joined: Tue May 01, 2012 9:08 pm

Re: IO UI Updated - feedback and issues

by jwcooper on Tue Nov 24, 2020 12:02 pm

cjdshaw wrote:
sahillyard wrote:You might want to reconsider the font used in the floating text boxes used with the graphs. The dark blue font that contains the data on a black background is difficult to read.
Thanks

Do you mean in light (non-dark) mode? The dark mode floating boxes are easy to read for me, but the issue is more that in light mode, the floating box bg is still dark, making lots of the text hard to read, particularly the purple one
Screenshot 2020-11-20 at 19.36.20.png


Thanks for the screenshot, we've filed an issue and will fix this one as well.

jwcooper
 
Posts: 732
Joined: Tue May 01, 2012 9:08 pm

Re: IO UI Updated - feedback and issues

by jwcooper on Tue Nov 24, 2020 12:05 pm

pmezey wrote:On a small screen (e.g. iPhone), the single feed data details clips one of the two most important columns: "Created At". I have to rotate the phone to see more and it still clips part of the timestamp. It seems the Location column is taking an enormous amount of space. I'm sure that is important to some use cases, but I would argue that Timestamp and Value are the two most important. The timestamp is hugely important to understand if your system is still functioning as expected.
IMG_7737 (1).jpeg


Thank you for the screenshot and the feedback. I've filed the issue for this. I think the best approach here is going to be dropping the "Location" column on vertical mobile displays and show it only for horizontal. That should give the full date and value.

jwcooper
 
Posts: 732
Joined: Tue May 01, 2012 9:08 pm

Re: IO UI Updated - feedback and issues

by tcooper on Tue Nov 24, 2020 1:24 pm

Barry99 wrote:Hi. This "update" really doesn't help. The colours you've chosen may be OK to you but if your red/green colourblind like me, and one in every hundred males are the same, then it definitely doesn't help. Please either revert to the original colours or give us the choice of colour.


Thanks for the heads up on this. We are working really hard on our accessibility issues, and for our small team it is a huge project. We will absolutely have a solution in place for those who are colorblind, but it might take some time for us to finish building this out.

Can you confirm the biggest issue is with the gauge and slider in dark mode on the dashboard? Any other major issues?

For now, can you try switching to light mode in the dashboard and see if that fixes the contrast issues you have?

tcooper
 
Posts: 49
Joined: Mon Apr 23, 2012 10:31 pm
Location: Minneapolis, MN

Re: IO UI Updated - feedback and issues

by klif on Tue Nov 24, 2020 11:34 pm

Hi
I noticed today an odd artifact appear on a circular gauge. See the attached image. Also the text on the lower gauge isn’t right but that problem has already been reported. This is on an iPhone using safari.
Attachments
F258FA1D-023E-4D31-8F7E-E4CB627768C2.jpeg
F258FA1D-023E-4D31-8F7E-E4CB627768C2.jpeg (75.33 KiB) Viewed 30 times

klif
 
Posts: 4
Joined: Thu Mar 12, 2020 7:26 pm

Re: IO UI Updated - feedback and issues

by FirstFloor322 on Wed Nov 25, 2020 8:04 am

FirstFloor322 wrote:the text on the buttons look distorted......sugesstion make the button width adjustable.....also if possible let the buttons retain their position when other one is clicked, they go back to off state when other buttons are clicked

can someone help me with this?? pls.....

FirstFloor322
 
Posts: 3
Joined: Wed Nov 11, 2020 12:45 am

Re: IO UI Updated - feedback and issues

by jwcooper on Wed Nov 25, 2020 11:47 am

FirstFloor322 wrote:
FirstFloor322 wrote:the text on the buttons look distorted......sugesstion make the button width adjustable.....also if possible let the buttons retain their position when other one is clicked, they go back to off state when other buttons are clicked

can someone help me with this?? pls.....


Can you provide a screenshot? What browser? Is it desktop or mobile?

In regards to the momentary buttons, they are designed to work like physical hardware buttons. They click ON when you push them, and click back OFF when you release. If you need to maintain a specific state (between two states), a toggle switch is typically a good choice.

It's an interesting idea to have an option where you click a toggle and it stays clicked in (now that it's obvious with the UI the state it's in), but it would be replicating a lot of the toggle switch's behavior.

jwcooper
 
Posts: 732
Joined: Tue May 01, 2012 9:08 pm

Re: IO UI Updated - feedback and issues

by simos_iot on Fri Nov 27, 2020 5:34 pm

New UI looks much better particularly the white background.

I'd like to suggest better granularity on the line graphs, or better yet, the ability to select a custom range similar to Thingsboard. In addition, more sizing options on the line graphs...just can't get 3 across the screen which would be much better for many applications.

simos_iot
 
Posts: 9
Joined: Sun Mar 17, 2019 1:50 am

Re: IO UI Updated - feedback and issues

by trevorshannon on Sat Nov 28, 2020 7:03 pm

trevorshannon wrote:
5. In light mode, the stream widget seems to still display white text despite having a white background. The text is visible only when highlighting it as shown in the below screenshot.

Screen Shot 2020-11-11 at 4.06.59 PM.png



Any update pending for this? It would be nice to be able to read the stream widget content in light mode...

-trevorshannon

trevorshannon
 
Posts: 3
Joined: Wed Nov 11, 2020 11:42 am

Re: IO UI Updated - feedback and issues

by jwcooper on Mon Nov 30, 2020 1:46 pm

trevorshannon wrote:
trevorshannon wrote:
5. In light mode, the stream widget seems to still display white text despite having a white background. The text is visible only when highlighting it as shown in the below screenshot.

Screen Shot 2020-11-11 at 4.06.59 PM.png



Any update pending for this? It would be nice to be able to read the stream widget content in light mode...

-trevorshannon


I wasn't able to re-create this, but I think the issue is that you have the white color scheme chosen for the stream block. If you edit that block, you can change it to green or a few other color options.

jwcooper
 
Posts: 732
Joined: Tue May 01, 2012 9:08 pm

Please be positive and constructive with your questions and comments.