0

GroupSensors not working with ESP8266 - WDT crash on second
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by daemach on Thu Dec 03, 2015 1:43 pm

Perfect!

Can you give me some kind of ETA, please?

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by jwcooper on Thu Dec 03, 2015 3:22 pm

Less than a month, but probably next week sometime. That's about the best I can give for an estimate for now!

jwcooper
 
Posts: 666
Joined: Tue May 01, 2012 9:08 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by daemach on Thu Dec 10, 2015 4:46 pm

I put my air quality monitor online again today and don't see new feeds showing up in the iaqmon group. They should just appear when you implement this fix, correct?

FWIW, I tried using that stream block, but since the feeds aren't being created, it doesn't show the iaqmon group.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by jwcooper on Thu Dec 10, 2015 4:49 pm

I'm actually deploying the fix in a few minutes. They should show up automatically once the fix goes in.

jwcooper
 
Posts: 666
Joined: Tue May 01, 2012 9:08 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by daemach on Thu Dec 10, 2015 6:48 pm

Is it done? I still don't see anything :/ There might be another problem - it would be great to see a stream at the group level too.
Last edited by daemach on Thu Dec 10, 2015 6:59 pm, edited 1 time in total.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by jwcooper on Thu Dec 10, 2015 6:58 pm

Partially deployed. Going to be tomorrow until I can get the whole thing out there. Found some last minute issues.

jwcooper
 
Posts: 666
Joined: Tue May 01, 2012 9:08 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by daemach on Thu Dec 10, 2015 7:01 pm

OK - sounds good. I'll wait for you to post here, but I'll keep it running.

If you, or someone else, can come up with a quick example of how I might use that publish function with a serialnumber appended to the groupname that would be great. I don't know what the qos parameter does either.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by daemach on Fri Dec 11, 2015 2:04 pm

I finally got dynamic group names to work this morning and noticed that one group got duplicated.

I have one of the devices pinging now. : cureomatic-1016505ccf7f018d12

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by jwcooper on Fri Dec 11, 2015 2:41 pm

Nice work, might be useful for someone else down the road if you share in a new forum post how you did the dynamic names with mqtt.

All of the group code has been deployed as well. Everything should be working for having feed names be unique within the group scope and more.

jwcooper
 
Posts: 666
Joined: Tue May 01, 2012 9:08 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by daemach on Fri Dec 11, 2015 4:02 pm

I'll do that later.

It's not working on this end still. This is what is showing up in the stream block:

ERROR - group iaqmon: Validation failed: Feed limit reached. Please remove one of your feeds prior to creating a new feed.
ERROR - group CureOMatic_1016505CCF7F018D12: 757: unexpected token at 'temp,83
humidity,38'

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by jwcooper on Fri Dec 11, 2015 6:50 pm

Looks like you're also bumping up against the beta feed limit (10 max).

https://learn.adafruit.com/adafruit-io/data-policies

I'll look into the other issue as well.

jwcooper
 
Posts: 666
Joined: Tue May 01, 2012 9:08 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by daemach on Fri Dec 11, 2015 8:57 pm

FWIW, there isn't much point in having groups with only one feed :) The group example itself uses 2 feeds. Any chance the feed limit can be increased to at least 20?

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by daemach on Fri Dec 11, 2015 8:59 pm

I tried deleting several feeds and get a 500 error each time.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by jwcooper on Fri Dec 11, 2015 11:31 pm

We're definitely working on figuring out the best mix of data limits right now, and started out conservatively. It's a lot easier to bump up limits than it is to remove them later on.

Please try deleting your feeds again. It should work now.

jwcooper
 
Posts: 666
Joined: Tue May 01, 2012 9:08 pm

Re: GroupSensors not working with ESP8266 - WDT crash on sec

by daemach on Sat Dec 12, 2015 2:16 am

Oddly, deleting the first one worked but I can't seem to delete any more. No 500 error now, but the delete link doesn't do anything.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Please be positive and constructive with your questions and comments.