Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.
0

IO cloud cam - issue getting images into feed
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

IO cloud cam - issue getting images into feed

by subrosa on Thu Nov 12, 2015 4:34 pm

I'm following the Adafruit IO guide: https://learn.adafruit.com/cloud-cam-co ... dafruit-io

I ended up having to upgrade to Jessie to run the latest Node.JS, but that hasn't been the problem.

paul@sierra /tmp/aio_cam $ sudo adafruit-io camera start -f PiCamBackyard -m false -r 5

This command automatically creates the PiCamBackyard feed, and I add that feed to my dashboard...but I never get any images.

I see the process running correctly:

paul@sierra /tmp/aio_cam $ ps -efww | grep raspistill
root 3074 3062 0 12:26 ? 00:00:00 /opt/vc/bin/raspistill --timelapse 5000 --timeout 999999999 --quality 10 --nopreview --output /tmp/aio_cam/cam.jpg --width 640 --height 480

As you notice, I testing these with sudo, but the same result happen with a normal user.

Any thoughts?

Thanks!

subrosa
 
Posts: 38
Joined: Sun Jun 01, 2014 5:33 am

Re: IO cloud cam - issue getting images into feed

by subrosa on Fri Nov 13, 2015 3:32 am

Hrm, seems to be working now.

I guess there might be a timeout involved.

subrosa
 
Posts: 38
Joined: Sun Jun 01, 2014 5:33 am

Please be positive and constructive with your questions and comments.