0

Is Adafruit IO down?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: Is Adafruit IO down?

by bphick on Wed Nov 18, 2015 3:50 pm

Those of us that posted on this thread noted that it came back up for us without modification once all power was removed from the module and the power was then reapplied. What does your serial monitor connection say is happening?

bphick
 
Posts: 38
Joined: Tue Sep 15, 2015 4:45 pm

Re: Is Adafruit IO down?

by nramond on Wed Nov 18, 2015 6:45 pm

Thanks, in fact I tried to remove the power during one hour and now somehow the problem was solved.
I'm pretty sure that there is something on the server side too but don't know what.
Well, now it's working and I hope for a long time ;-)

Thanks again.

nramond
 
Posts: 26
Joined: Sat Oct 06, 2012 5:21 pm

Re: Is Adafruit IO down?

by bphick on Thu Nov 19, 2015 12:56 am

I found it had to be off for about the cycle period (in my case 10 sec.) before restarting, apparently to let everything clear, disconnect, etc. Also, I had one on battery backup that of course didn't disconnect when the power was removed... :0)

bphick
 
Posts: 38
Joined: Tue Sep 15, 2015 4:45 pm

Re: Is Adafruit IO down?

by nramond on Thu Nov 19, 2015 2:37 pm

Now it explains everything, you're absolutly right. Thumb up!

Also, I don't know if you experienced something like that but if I power the Huzzah ESP8266 with the FTDI cable (for debugging for example) it will send to io.adafruit weird data.
As soon as I power the Huzzah ESP8266 with the charger, everything go back to normal.
Some new aventure in sight ! :D

nramond
 
Posts: 26
Joined: Sat Oct 06, 2012 5:21 pm

Re: Is Adafruit IO down?

by bphick on Thu Nov 19, 2015 2:45 pm

I'm running one off the expensive Adafruit cable and one off the cheaper Adafruit cable.
Sometimes while plugging it in I am not smooth... resulting in crappy input as I watch from the Serial monitor. Solution... just plug it in again (and maybe again) until it gets it right. I have better experience plugging the cord into the board, and then putting it into the power supply or computer port... but for me, the expensive cord is not as easily accessible, so I get weird effects.

bphick
 
Posts: 38
Joined: Tue Sep 15, 2015 4:45 pm

Re: Is Adafruit IO down?

by bphick on Sat Nov 21, 2015 10:12 pm

jwcooper:
It's Saturday, and it's happening again after working all week...
Both of my feeds on two different PCs were down when I was checking (now) at 8:00 PM Saturday. The charts again said "no data." So I checked the serial monitors that said:
"Failed to publish temperature.
Failed to publish humidity"

And then I rebooted... both.

Once again, when I got one going and tried to get the second one going, the first one stopped... Same as last week and the beginning of this thread. I can't keep them both going at the same time... They are mutually exclusive.

I have just the stock standard Huzzah ESP8266 connected to a DHT22... all vanilla and hooked, as I said above, to a PC. All seems to check out from my end.

Another try at an upgrade this weekend at Adafruit.io?

bphick
 
Posts: 38
Joined: Tue Sep 15, 2015 4:45 pm

Re: Is Adafruit IO down?

by nramond on Sun Nov 22, 2015 1:38 pm

Hi, Once again I have a problem with the io.adafruit connection and my huzzah ESP8266.
Same problem but this time it doesn't make any change if I disconnect during the time period specified.
Well, I was coming from io.google and I prefer going back to it as It worked smooth as expected.

nramond
 
Posts: 26
Joined: Sat Oct 06, 2012 5:21 pm

Re: Is Adafruit IO down?

by bphick on Mon Nov 23, 2015 1:00 am

Where does one go to start io.google?

bphick
 
Posts: 38
Joined: Tue Sep 15, 2015 4:45 pm

Re: Is Adafruit IO down?

by fapuc2 on Mon Nov 23, 2015 3:57 am

Has anyone experienced example of code that how to use the library MQTT
that support enough for QoS 0 and 1

Regards

fapuc2
 
Posts: 13
Joined: Fri Oct 16, 2015 8:29 am

Re: Is Adafruit IO down?

by nramond on Mon Nov 23, 2015 5:15 am

You can find many tutorials about it. An IOT on the net for example : https://www.freeboard.io

My 2 cents.

nramond
 
Posts: 26
Joined: Sat Oct 06, 2012 5:21 pm

Re: Is Adafruit IO down?

by jwcooper on Mon Nov 23, 2015 11:53 am

bphick wrote:jwcooper:
It's Saturday, and it's happening again after working all week...
Both of my feeds on two different PCs were down when I was checking (now) at 8:00 PM Saturday. The charts again said "no data." So I checked the serial monitors that said:
"Failed to publish temperature.
Failed to publish humidity"

And then I rebooted... both.

Once again, when I got one going and tried to get the second one going, the first one stopped... Same as last week and the beginning of this thread. I can't keep them both going at the same time... They are mutually exclusive.

I have just the stock standard Huzzah ESP8266 connected to a DHT22... all vanilla and hooked, as I said above, to a PC. All seems to check out from my end.

Another try at an upgrade this weekend at Adafruit.io?


Have you opened an issue on our MQTT library Github repository? Please include as many details as possible. It sounds like this could be an issue there. If not, we'll move it to the appropriate repository. It's too difficult to track issues in the forums.
https://github.com/adafruit/Adafruit_MQTT_Library

Adafruit IO is still in beta with code changes happening rapidly, possibly breaking things as we go. Anyone with access to Adafruit IO is a beta tester that has opted-in. There will be bugs, but since we've started accepting testers, IO has become far more responsive, and stable with more features added every week. If anyone is not comfortable with the standard beta issues; it's ok to wait until we remove the beta flag before trying it out again.

jwcooper
 
Posts: 666
Joined: Tue May 01, 2012 9:08 pm

Re: Is Adafruit IO down?

by adafruit2 on Mon Nov 23, 2015 8:51 pm

hey justin, its way better to do support for MQTT connection issues in the forums than in the github issues! lets please keep all non-known-bugs here.

*if you're having issues connecting* make sure you have the latest MQTT library and are using the latest examples *first* since we have moved to MQTT 3.1.1 and also gotten rid of client ID's (since people were colliding)

then make a new thread, cuz this one is way too confusing

adafruit2
Site Admin
 
Posts: 18482
Joined: Fri Mar 11, 2005 7:36 pm

Re: Is Adafruit IO down?

by bphick on Mon Nov 23, 2015 10:01 pm

Thanks for the affirmation adafruit2 and the quick response on GitHub! :-)
Do you ever get to sleep or take a break?? Anyway, much appreciated on this end, but don't self destruct.

bphick
 
Posts: 38
Joined: Tue Sep 15, 2015 4:45 pm

Re: Is Adafruit IO down?

by bphick on Mon Nov 23, 2015 10:01 pm

Thanks for the affirmation adafruit2 and the quick response on GitHub! :-)
Do you ever get to sleep or take a break?? Anyway, much appreciated on this end, but don't self destruct.

bphick
 
Posts: 38
Joined: Tue Sep 15, 2015 4:45 pm

Re: Is Adafruit IO down?

by bphick on Tue Nov 24, 2015 1:41 am

Jwcooper: As previously stated, I'm a total newbie... so to get clearification back a while ago you told me to "We upgraded some software components that were causing connection issues with MQTT due to the higher volumes now that we added a lot more beta testers. This is why we're still in beta! ;)

Please try again, and let us know if it's working for you.

Also, with the latest mqtt library, you shouldn't need to set a client id at all. We've upgraded the library to support mqtt 3.1.1 which allows for the server to generate the client id. Pull request that was merged in is here: https://github.com/adafruit/Adafruit_MQ ... ry/pull/10"

SOOO, I went to https://github.com/adafruit/Adafruit_MQ ... ry/pull/10 to get the code, but am totally confused by what I see on GitHub. Where exactly do I go to get the most up to date code that works with IDE 1.6.5. I tried to cut and paste code from the one that I could find, but they were fixes for IDE 1.6.6... and this is for the ESP8266s running the example code for Temp/Humidity. What am I missing?? I tried the code I found, and it would not compile on IDE 1.6.5.

bphick
 
Posts: 38
Joined: Tue Sep 15, 2015 4:45 pm

Please be positive and constructive with your questions and comments.