0

Line chart bug?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Line chart bug?

by mrxtreme on Mon Nov 30, 2015 4:01 pm

Hello,

I just added a line chart scaled 0 - 100 and pass it an int which is within the range. The chart scales (upper and lower range) to the sent high to low values (in my case values around 40) rather than displaying the full scale of 0-100..

If I change the setup scaling to 1 - 100 it displays correctly. I have not tried other scaling values to figure out what the limits of the bug are.

Pics attached showing the issue. Let me know if you need more info/data.

James
Attachments
Line Chart scale 1-100.jpg
This is what I expected except is doesn't go to zero
Line Chart scale 1-100.jpg (33.92 KiB) Viewed 375 times
Bad Line Chart scale 0-100.jpg
Unexpected display from the feed when scaling is set 0-100
Bad Line Chart scale 0-100.jpg (32.87 KiB) Viewed 375 times

mrxtreme
 
Posts: 10
Joined: Fri Aug 03, 2012 12:46 am

Re: Line chart bug?

by jwcooper on Mon Nov 30, 2015 5:00 pm

Thank you for this bug report. This should be able to be reproduced and fixed/worked around. It might be a bug with the scaling of nvd3 charts (the library we use) when the value set is zero.

jwcooper
 
Posts: 666
Joined: Tue May 01, 2012 9:08 pm

Re: Line chart bug?

by whatski on Tue Apr 23, 2019 6:44 am

I am having the same problem, but in addition, when I apply the workaround of setting the min value to 1 instead of 0, the scaling looks OK but only until I save the dashboard changes, at which point it reverts back to the improper scaling.
So this little workaround did not work for me.
Can someone please comment on whether they see the same problem, and if the workaround fixes it?

whatski
 
Posts: 14
Joined: Thu Feb 15, 2018 10:40 am

Please be positive and constructive with your questions and comments.