Black Lives Matter - Action and Equality. ... Adafruit joins the Stop Hate for Profit campaign.
0

Dashboard issues
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

Dashboard issues

by daemach on Sat Dec 19, 2015 1:16 pm

Here are a few comments related to dashboards:

  • Performance - the page gets really laggy with more than 2 line charts.
  • Layout - I lay these out horizontally, but when I log in again they are arranged vertically, so I have to scroll to see the bottom widget. Retaining the layout, especially if mobile and desktop could be recognized and handled separately, would be great.
  • https://io.adafruit.com/daemach/airnode-esp keeps crashing in chrome after a period of time.
  • It would be really nice to be able to change colors at or above specified thresholds.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: Dashboard issues

by jwcooper on Sun Dec 20, 2015 1:39 pm

Is the performance still laggy with the new line charts we deployed late Friday?

The other feedback is also great. Adding this to our internal issues tracker.

jwcooper
 
Posts: 677
Joined: Tue May 01, 2012 9:08 pm

Re: Dashboard issues

by daemach on Sun Dec 20, 2015 2:37 pm

I can't tell - the mqtt library is failing on connect now. It's no longer sending data.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: Dashboard issues

by daemach on Mon Dec 21, 2015 9:43 am

It's working for one of my devices now and the performance does seem to be better.

I'm getting that unexpected token error in the stream block for another device, though, and its feeds aren't being created.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: Dashboard issues

by daemach on Mon Dec 21, 2015 10:58 am

The dashboard tab crashes after a while too. Seems to crash faster with more blocks, so it's likely a memory leak.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: Dashboard issues

by daemach on Mon Dec 21, 2015 11:51 am

Now there are no errors in the stream, but feeds aren't being created.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: Dashboard issues

by jwcooper on Mon Dec 21, 2015 11:53 am

Try restarting your programs. We just migrated to new servers and updated the DNS. Old servers are offline.

jwcooper
 
Posts: 677
Joined: Tue May 01, 2012 9:08 pm

Re: Dashboard issues

by daemach on Mon Dec 21, 2015 12:25 pm

I'm getting success messages on my side - there are just no feeds being created. Should I get success messages with the MQTT library if I'm hitting the old servers? I've reset the devices several times. They are esp8266 connecting directly to the internet via wifi.

Can you create a new DNS entry that CNAMEs the existing one for temporary use? If you think it's a caching/propagation issue, that will force a new read.

Or maybe you could add the old IP addresses to the new servers...
Last edited by daemach on Mon Dec 21, 2015 12:32 pm, edited 1 time in total.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: Dashboard issues

by jwcooper on Mon Dec 21, 2015 12:27 pm

Oh, this is the unexpected token issue? We'll be digging into that ASAP yet.

jwcooper
 
Posts: 677
Joined: Tue May 01, 2012 9:08 pm

Re: Dashboard issues

by daemach on Mon Dec 21, 2015 2:07 pm

I'm seeing data and errors again. Yep- unexpected token.

daemach
 
Posts: 143
Joined: Fri Feb 13, 2009 2:07 pm

Re: Dashboard issues

by pooldr on Mon Dec 28, 2015 12:01 pm

i'm getting an error also, says "Invalid AIO Key"
Tried resetting Token key, but still comes back invalid key from curl request.

pooldr
 
Posts: 18
Joined: Mon Sep 30, 2013 8:56 am
Location: Philadelphia

Please be positive and constructive with your questions and comments.