Black Lives Matter - Action and Equality. ... Adafruit is part of the Stop Hate for Profit campaign. Adafruit is open and shipping.
0

Can't seem to get any feeds to work (server error 500)
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

Can't seem to get any feeds to work (server error 500)

by markwal on Wed Jan 13, 2016 8:47 pm

I've tried the MQTT library, the RESTful library and curl from the command line. I get server error 500 any which way I go.

Weirdly, if I do this one:
curl -H "Content-Type: application/json" -X POST -d "{\"name\":\"<FEEDname>\"}" -H "x-aio-key: <AIOkey>" http://io.adafruit.com/api/feeds.json

It responds with:
500 Internal Server Error
If you are the administrator of this website, then please read this web application's log file and/or the web server's log file to find out what went wrong.

But creates the feed anyway.

With this one:
curl -H "Content-Type: application/json" -X POST -d "{\"value\":\"456\"}" -H "x-aio-key: <AIOkey>" http://io.adafruit.com/api/feeds/<FEEDname>/data/send.json

I'm not so lucky. I get the 500, but it doesn't send the data.

Also, even when I have feeds, this one returns "[]":
curl -H "Content-Type: application/json" -X GET -H "x-aio-key: <AIOkey>" http://io.adafruit.com/api/feeds.json

markwal
 
Posts: 11
Joined: Tue Apr 14, 2015 6:16 pm

Re: Can't seem to get any feeds to work (server error 500)

by markwal on Wed Jan 13, 2016 8:57 pm

I fixed it by deleting my IO data and account and starting over.

markwal
 
Posts: 11
Joined: Tue Apr 14, 2015 6:16 pm

Please be positive and constructive with your questions and comments.


cron