Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

AIO not working
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

AIO not working

by kilovision on Wed Jan 20, 2016 9:30 am

My Photon stopped posting to AIO suddenly yesterday. It occasionally works, but usually fails. I also tried setting up an IFTTT recipe connecting a Maker event to AIO, but IFTTT responds that it can't verify the feed I've selected. What happened over the course of the last 24 hours that made AIO so unstable.

I'd be happy to share my webhook for the Photon if that would help. Seeing as it was working and then stopped, I don't think it will.

kilovision
 
Posts: 8
Joined: Mon Jan 18, 2016 10:42 am

Re: AIO not working

by jwcooper on Thu Jan 21, 2016 3:14 pm

Everything should be operational now. We found some code that was causing tables to get locked up, impacting performance for everyone. This has been resolved.

jwcooper
 
Posts: 679
Joined: Tue May 01, 2012 9:08 pm

Re: AIO not working

by kilovision on Fri Jan 22, 2016 8:54 am

Went to test, but am now getting:
{"data":"{\"code\":\"ECONNREFUSED\",\"errno\":\"ECONNREFUSED\",\"syscall\":\"connect\"}","ttl":"60","published_at:....

io.adafruit.com appears to be down.

kilovision
 
Posts: 8
Joined: Mon Jan 18, 2016 10:42 am

Re: AIO not working

by mlubbers on Fri Jan 22, 2016 9:23 am

Adafruit.IO appears to be down again. I am optimistic that the kinks will get worked out. It is really nice to have this server for getting started with MQTT development.

Thanks Adafruit

mlubbers
 
Posts: 2
Joined: Thu Jan 21, 2016 9:53 am

Re: AIO not working

by sellensr on Sat Jan 23, 2016 7:32 pm

I created a collection of feeds through the web interface, then tried to get response through my ESP8266. I seem to get a successful link, but with a response indicating no feeds exist. Am I doing something wrong, or is the system not working quite right?

Requesting URL:
GET /api/feeds?X-AIO-Key=860[a bunch of key redacted]0e8 HTTP/1.1
Host: io.adafruit.com
Connection: close

Response:
... HTTP/1.1 200 OK
Content-Type: application/json; charset=utf-8
Transfer-Encoding: chunked
Connection: close
Status: 200 OK
Cache-Control: max-age=0, private, must-revalidate
X-XSS-Protection: 1; mode=block
X-Request-Id: 44201be8-95bd-4828-9b8e-92fe7aa2e043
ETag: W/"58e0494c51d30eb3494f7c9198986bb9"
X-Frame-Options: SAMEORIGIN
X-Runtime: 0.022935
X-Content-Type-Options: nosniff
Date: Sat, 23 Jan 2016 23:25:12 GMT
X-Powered-By: Phusion Passenger 5.0.22
Server: nginx + Phusion Passenger 5.0.22
Access-Control-Allow-Origin: *
Access-Control-Allow-Credentials: true
Access-Control-Allow-Methods: GET
Access-Control-Allow-Headers: DNT,X-AIO-Key,Accept,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type

3
[shouldn't the feed descriptors be inside these square brackets?]

0

sellensr
 
Posts: 47
Joined: Tue Nov 06, 2012 9:41 pm

Re: AIO not working

by kilovision on Sat Jan 23, 2016 7:38 pm

@sellensr, please create a separate topic for your issue. This topic is for an issue I am having regarding a feed that was working but suddenly stopped and gave errors indicating an issue with the service.

kilovision
 
Posts: 8
Joined: Mon Jan 18, 2016 10:42 am

Re: AIO not working

by kilovision on Sat Jan 23, 2016 7:40 pm

@jwcooper, my feeds started working again and have been stable all day. Thanks.

kilovision
 
Posts: 8
Joined: Mon Jan 18, 2016 10:42 am

Re: AIO not working

by sellensr on Sat Jan 23, 2016 8:03 pm

@kilovision if yours is working, then I'll take my question elsewhere, as the system is obviously up now... Cheers

sellensr
 
Posts: 47
Joined: Tue Nov 06, 2012 9:41 pm

Re: AIO not working

by kilovision on Sat Jan 23, 2016 11:04 pm

No worries. I just wanted to make sure your issue receives attention too.

kilovision
 
Posts: 8
Joined: Mon Jan 18, 2016 10:42 am

Please be positive and constructive with your questions and comments.