Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.


by RedBaron on Mon Feb 08, 2016 7:50 am


I'm a MQTT newbie. First I wanted to try some easy examples with my Windows PC. I found the MQTT.fx tutorial at adafruit. I followed these instructions https://learn.adafruit.com/desktop-mqtt-client-for-adafruit-io. I tried to connect to the server on several days at different times. I never got a connection. I checked my user data and the AIO key sevaral times too. I can't find a mistake. Can you give me a hint?

Kind regards RedBaron

This are my settings
MQTT.fx settings 1
mqtt1.png (32.05 KiB) Viewed 417 times

MQTT.fx settings 2. As password is the same as i use to login to my dashboard
mqtt2.png (26.34 KiB) Viewed 417 times

MQTT.fx settings 3
mqtt3.png (25.55 KiB) Viewed 417 times

"Proxy" and "Last Will and Testament" are left blank

This is the log:
2016-02-08 12:36:56,508 INFO --- ScriptingManager : Found action with name: Switch Fountain Test
2016-02-08 12:38:33,930 INFO --- BrokerConnectorController : onConnect
2016-02-08 12:38:34,117 INFO --- MqttFX ClientModel : MqttClient with ID dbc55841fe.................7390f2fa5 assigned.
2016-02-08 12:38:34,630 ERROR --- MqttFX ClientModel : Error when connecting
org.eclipse.paho.client.mqttv3.MqttSecurityException: Not authorized to connect
at org.eclipse.paho.client.mqttv3.internal.ExceptionHelper.createMqttException(ExceptionHelper.java:28) ~[org.eclipse.paho.client.mqttv3-1.0.2.jar:?]
at org.eclipse.paho.client.mqttv3.internal.ClientState.notifyReceivedAck(ClientState.java:885) ~[org.eclipse.paho.client.mqttv3-1.0.2.jar:?]
at org.eclipse.paho.client.mqttv3.internal.CommsReceiver.run(CommsReceiver.java:118) ~[org.eclipse.paho.client.mqttv3-1.0.2.jar:?]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_66]
2016-02-08 12:38:34,643 INFO --- ScriptsController : Clear console.
2016-02-08 12:38:34,644 ERROR --- BrokerConnectService : MqttSecurityException: Not authorized to connect

Posts: 2
Joined: Wed Jan 13, 2016 5:08 am

Re: MQTT.fx

by adafruit2 on Mon Feb 08, 2016 6:40 pm

your username password looks too short, it should be the same as your IO key!
https://learn.adafruit.com/desktop-mqtt ... onfiguring

Site Admin
Posts: 20064
Joined: Fri Mar 11, 2005 7:36 pm

Re: MQTT.fx

by RedBaron on Tue Feb 09, 2016 2:59 am

that solved the problem. thank you

Posts: 2
Joined: Wed Jan 13, 2016 5:08 am

Please be positive and constructive with your questions and comments.