0

vs1053b music maker Mic Input or Line in
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: vs1053b music maker Mic Input or Line in

by jeramy_morrill on Fri Nov 10, 2017 12:39 pm

hey yeah way past that.

I've gotten the plugin file to load every time now. but sometimes it fails when it's being read sometimes it doesn't. It feels like its a timing issue. like sometimes the SD card can be accessed sometimes it can't and if you try to access it at the times it's not available it wont read. I've even had it outputting the file and in the middle it turns into ??? ...

Is there something trying to access the SD or switching the MISO MOSI ? should I switch to software SPI? I keep thinking I have it working and then bam... it stops... :(

jeramy_morrill
 
Posts: 22
Joined: Wed Jul 19, 2017 4:47 pm

Re: vs1053b music maker Mic Input or Line in

by jeramy_morrill on Fri Nov 10, 2017 2:09 pm

Hey! I figured it out!

Sooo it was just something silly on my part. I was powering the SD card with a separate power source than the feather board. So I guess they were cycling different or something! I dunno I know programming a lot better than this part haha. Soo yeah thank you so much for all the help. Lesson well learned on my part!

Last question. What about doing that causes problems? Or is that to long of an answer?

jeramy_morrill
 
Posts: 22
Joined: Wed Jul 19, 2017 4:47 pm

Re: vs1053b music maker Mic Input or Line in

by adafruit_support_mike on Sat Nov 11, 2017 2:46 am

There are many different reasons why that kind of thing can fail, so you pretty much have to examine the signals and see what's happening near the point of failure.

The three most likely options are:

- missing or weak GND connection
- current load pulling the VCC rail low enough to force some of the hardware to reboot
- problems when one side resets but the other doesn't

adafruit_support_mike
 
Posts: 45288
Joined: Thu Feb 11, 2010 2:51 pm

Re: vs1053b music maker Mic Input or Line in

by jeramy_morrill on Mon Nov 13, 2017 2:13 pm

gotten everything to work and it records, but not I'm getting nothing but weird silence-ish noise from the recording?

I'm using the electret breakout board and have the vcc coming from 3v3 off the vs1053 board the output is going to mic+ and the gnd to mic-. Any suggestions?

jeramy_morrill
 
Posts: 22
Joined: Wed Jul 19, 2017 4:47 pm

Re: vs1053b music maker Mic Input or Line in

by jeramy_morrill on Mon Nov 13, 2017 2:23 pm

I've attached what the levels of the sound files look like. They all look the same except for length. Which would indicate to me that the signal isn't coming in at all or is way to weak? I have tried adjusting the trim pot on the bottom of the board but haven't seen any other results.
Attachments
2017-11-13.png
2017-11-13.png (12.53 KiB) Viewed 36 times

jeramy_morrill
 
Posts: 22
Joined: Wed Jul 19, 2017 4:47 pm

Re: vs1053b music maker Mic Input or Line in

by jeramy_morrill on Tue Nov 14, 2017 1:38 pm

hey, so the problem is for some reason this is backwards:
Code: Select all | TOGGLE FULL SIZE
musicPlayer.startRecordOgg(false); // use microphone (for linein, pass in 'false')


My input is coming from mic+ not line and linein but it only works on false.

jeramy_morrill
 
Posts: 22
Joined: Wed Jul 19, 2017 4:47 pm

Please be positive and constructive with your questions and comments.