0

Hallowing - dead?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Hallowing - dead?

by llung on Sun Jan 13, 2019 11:57 pm

DSC07619.JPG
back of board. It's plugged into my laptop.
DSC07619.JPG (620.88 KiB) Viewed 168 times

I just bought three HalloWing devices. Order number is 1951684.
Two of the devices seem to work just fine. When I turn them on, I get the default "eye" on the screen.
The third device doesn't work. I get a very dim image of the Adafruit splashscreen (too dim to take a picture of), then the screen goes black. Comparing it to the two working units, it looks like the backlight on the unit is broken as there is no light whatsoever where the ribbon cable is located.

Attached is the picture of the rear (there's nothing to show of the front because it's just a dead looking board). The back image shows the yellow LED in an "on" state. It's actually flashing.

I haven't tried to program the bad unit yet. My laptop seems to recognize it when I plug it in but I don't want to waste time fiddling with it if it's broken.
Thoughts?
tkx

llung
 
Posts: 16
Joined: Mon Jun 29, 2015 9:11 pm

Re: Hallowing - dead?

by adafruit_support_carter on Tue Jan 15, 2019 4:10 pm

Maybe it just didn't loaded with the example eye ball program. You say your laptop recognizes it - what does it show up on your computer as?

adafruit_support_carter
 
Posts: 11941
Joined: Tue Nov 29, 2016 2:45 pm

Re: Hallowing - dead?

by llung on Thu Jan 17, 2019 2:02 pm

The Device Manager has it as "USB Serial Device (COM4)"

I also did the double-tap of the reset button to bring up HALLOBOOT, then I dragged Spooky_Eye_Human.UF2 into that directory, it disconnected as expected, and I waited a couple of minutes for good measure. I no longer see a ghost of the Adafruit splash screen as I had before but I can see a quick flicker of the entire screen (very dimly) followed by black. The yellow LED on the read flickers as before. A double-top of the reset button puts me back into HALLOBOOT so that still works.

llung
 
Posts: 16
Joined: Mon Jun 29, 2015 9:11 pm

Re: Hallowing - dead?

by adafruit_support_carter on Thu Jan 17, 2019 2:06 pm

This sounds like maybe there's an issue with the screen. There are somethings we can try - have you set up a way to program the Hallowing yet? Like with Arduino or CircuitPython?

adafruit_support_carter
 
Posts: 11941
Joined: Tue Nov 29, 2016 2:45 pm

Re: Hallowing - dead?

by llung on Thu Jan 17, 2019 2:20 pm

I think so. I just updated the Arduino IDE to the latest and board manager; and can select "Adafruit Hallowing M0" as my board. Haven't tried to actually write and upload code yet.

llung
 
Posts: 16
Joined: Mon Jun 29, 2015 9:11 pm

Re: Hallowing - dead?

by adafruit_support_carter on Thu Jan 17, 2019 2:24 pm

See if you can get the blink example to load and run. If it is just a screen issue, that should still work, since it's just the little red LED.
https://learn.adafruit.com/adafruit-hal ... blink-6-21

adafruit_support_carter
 
Posts: 11941
Joined: Tue Nov 29, 2016 2:45 pm

Re: Hallowing - dead?

by llung on Thu Jan 17, 2019 2:50 pm

Yes, this works. The red LED blinks 1 sec on, 1 sec off.
I changed the blink rate too just to make sure.

llung
 
Posts: 16
Joined: Mon Jun 29, 2015 9:11 pm

Re: Hallowing - dead?

by adafruit_support_carter on Thu Jan 17, 2019 2:51 pm

Cool. OK, we can try something. Here's a simple sketch that blinks the screen's backlight - the screen should look like it's turning off / on. Try running this and see what happens.
Code: Select all | TOGGLE FULL SIZE
void setup() {
  pinMode(7, OUTPUT);
}

void loop() {
  digitalWrite(7, HIGH);
  delay(1000);
  digitalWrite(7, LOW);
  delay(1000);
}

adafruit_support_carter
 
Posts: 11941
Joined: Tue Nov 29, 2016 2:45 pm

Re: Hallowing - dead?

by llung on Thu Jan 17, 2019 3:01 pm

Nothing. The LCD screen stays black.

llung
 
Posts: 16
Joined: Mon Jun 29, 2015 9:11 pm

Re: Hallowing - dead?

by adafruit_support_carter on Thu Jan 17, 2019 3:05 pm

Just for sanity check - can you try same thing on one of the ones that seems to be working.

adafruit_support_carter
 
Posts: 11941
Joined: Tue Nov 29, 2016 2:45 pm

Re: Hallowing - dead?

by llung on Thu Jan 17, 2019 3:12 pm

I'll have to try that later today as I only have the bad one with me at the moment. Maybe in about 3+ hrs.
Any other test you'd like me to try?

llung
 
Posts: 16
Joined: Mon Jun 29, 2015 9:11 pm

Re: Hallowing - dead?

by adafruit_support_carter on Thu Jan 17, 2019 3:18 pm

Nah. That's it. Pretty sure you just have a bad screen. But just want to double check since you have working ones available.

adafruit_support_carter
 
Posts: 11941
Joined: Tue Nov 29, 2016 2:45 pm

Re: Hallowing - dead?

by llung on Thu Jan 17, 2019 3:20 pm

ok. Will post result later.
tkx

llung
 
Posts: 16
Joined: Mon Jun 29, 2015 9:11 pm

Re: Hallowing - dead?

by llung on Thu Jan 17, 2019 6:46 pm

i just tried it on one of the other two Halllowings and the LCD panel flashes white on and off.

llung
 
Posts: 16
Joined: Mon Jun 29, 2015 9:11 pm

Re: Hallowing - dead?

by adafruit_support_carter on Thu Jan 17, 2019 6:49 pm

OK. Thanks for testing that. Let's replace that other one.

Send an email to [email protected] with a link to this thread and they can send you a new Hallowing.

adafruit_support_carter
 
Posts: 11941
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.