0

Feather Sense not showing up as COM port after one upload
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Feather Sense not showing up as COM port after one upload

by ghost3828 on Thu Aug 05, 2021 4:53 pm

Hi,

Just tried to use my Feather nRF52840 Sense for the first time. Connected it via USB and uploaded the following code via PlatformIO, using the Adafruit Feather Bluefruit Sense board option:

Code: Select all | TOGGLE FULL SIZE
#include <Arduino.h>

void setup() {
  pinMode(LED_BLUE, OUTPUT);
  pinMode(LED_RED, OUTPUT);
  pinMode(PIN_BUTTON1, INPUT_PULLUP);
}

void loop() {
 
  bool buttonState = digitalRead(PIN_BUTTON1);

  if (buttonState == HIGH)
  {
    digitalWrite(LED_RED, HIGH);
    digitalWrite(LED_BLUE, HIGH);
  }else{
    digitalWrite(LED_RED, LOW);
    digitalWrite(LED_BLUE, LOW);
  }
 
}



It seems the initial upload was successful (except there is an odd delay with the button push turning off the LEDs). But after this, the board no longer shows up as a COMPORT. I've tried multiple USB cables, USB ports, and two different computers, and no luck.

Anyone know what could be going on here?

Thanks,
Wyatt

ghost3828
 
Posts: 10
Joined: Tue Dec 29, 2020 4:18 pm

Re: Feather Sense not showing up as COM port after one uploa

by ghost3828 on Thu Aug 05, 2021 10:16 pm

So after reading https://learn.adafruit.com/bluefruit-nrf52-feather-learning-guide/using-the-bootloader, I determined that I can reconnect the Feather Sense via USB by double-tapping the reset button. I have to do this after every time I upload a sketch. That page clearly states no manual intervention should be required to upload code, so I'm still not sure what's going on?

Unrelatedly, with both the Arduino IDE and PIO, I'm getting a compile error when I try to use Serial? Still reading though the tutorial, but would appreciate if anyone has a quick fix for that.

Thanks!

ghost3828
 
Posts: 10
Joined: Tue Dec 29, 2020 4:18 pm

Re: Feather Sense not showing up as COM port after one uploa

by ghost3828 on Fri Aug 06, 2021 4:48 pm

Made a new thread for my issues re: Serial: https://forums.adafruit.com/viewtopic.php?f=57&t=182025

ghost3828
 
Posts: 10
Joined: Tue Dec 29, 2020 4:18 pm

Please be positive and constructive with your questions and comments.