0

Double-clicking ESP32-S2 RST button does not bring up bootlo
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Double-clicking ESP32-S2 RST button does not bring up bootlo

by Funkagenda on Sun May 22, 2022 1:35 pm

I bought an ESP32-S2 last week in order to deploy the ESPHole Ad Blocker on my network, but double-clicking the reset button on the board isn't launching the bootloader or showing the FTHRS2BOOT device as a drive.

Any ideas? Not really sure how to recover from this.

Funkagenda
 
Posts: 10
Joined: Fri May 20, 2022 4:36 pm

Re: Double-clicking ESP32-S2 RST button does not bring up bo

by dastels on Sun May 22, 2022 2:11 pm


dastels
 
Posts: 10106
Joined: Tue Oct 20, 2015 3:22 pm

Re: Double-clicking ESP32-S2 RST button does not bring up bo

by jwiede on Sun May 22, 2022 3:58 pm

Depending on precisely which ESP32S2 Feather you have, you might need to press the "BOOT" button when the neostar shows purple, not the "RST" button. Give that a try?

jwiede
 
Posts: 14
Joined: Thu Sep 27, 2012 9:15 pm

Re: Double-clicking ESP32-S2 RST button does not bring up bo

by TI545 on Sun May 22, 2022 9:39 pm

Jwiede. You joined ada forums 10 years ago and this is your second post? Welcome back!

On topic, it does take some practice with the double-tap. Timing. Once I got it, it got easier.

TI545
 
Posts: 51
Joined: Tue Feb 27, 2018 5:25 pm

Re: Double-clicking ESP32-S2 RST button does not bring up bo

by Funkagenda on Mon May 23, 2022 12:00 am



I guess the thing I missed was the "wait for purple LED" bit, because when I double-tapped and waited for the purple LED on the second tap, it worked. So thanks!

Funkagenda
 
Posts: 10
Joined: Fri May 20, 2022 4:36 pm

Re: Double-clicking ESP32-S2 RST button does not bring up bo

by dastels on Mon May 23, 2022 11:47 am

Excellent!

Dave

dastels
 
Posts: 10106
Joined: Tue Oct 20, 2015 3:22 pm

Re: Double-clicking ESP32-S2 RST button does not bring up bo

by jwiede on Mon May 23, 2022 12:18 pm

Glad you got it working!

@TI545, just haven't really had anything I needed to discuss before. ;D

jwiede
 
Posts: 14
Joined: Thu Sep 27, 2012 9:15 pm

Please be positive and constructive with your questions and comments.