On Saturday, August 13, 2022 we will be working on the Adafruit Customer Support Forums. If you visit over the weekend and things are not complete yet, please check back later, https://adafruit.com/forumupdates
0

TFT NOT WORKING PROPERLY ON ESP32-S
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

TFT NOT WORKING PROPERLY ON ESP32-S

by lvillaautomata on Wed Jun 29, 2022 11:04 pm

Order #: 2857182-3871025802

As others have noted (viewtopic.php?f=57&t=191646), the TFT display on my Feather has a backlight but nothing is actually displayed. I popped into the Discord to ask a general question in the #help-with-circuitpython channel about the plug & play nature of the display and they recommended following the tutorials which I already did. I attempted them again and yet the behavior is the same.

I don't even get the ROM image that someone displayed in the channel.

Is there a path forward here?

Best,

lvillaautomata
 
Posts: 6
Joined: Fri Feb 04, 2022 12:06 am

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by mikeysklar on Thu Jun 30, 2022 2:59 pm

As a forum admin I cannot lookup your order. What is the controller / display you are using?

Can you post a photo of your setup including anything else connected and if you did any soldering please show those too.

mikeysklar
 
Posts: 8111
Joined: Mon Aug 01, 2016 8:10 pm

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by lvillaautomata on Thu Jun 30, 2022 3:38 pm

There's nothing connected to it except the usb-c.

I also haven't soldered anything to it. I ordered it June 1st and received it maybe a week or two later.

I can share a pic but I haven't done anything to it beside remove it from the packaging it arrived in.

Best,

lvillaautomata
 
Posts: 6
Joined: Fri Feb 04, 2022 12:06 am

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by mikeysklar on Thu Jun 30, 2022 8:34 pm

If there is nothing else connected or soldered please let us know the Ada part# you are using.

mikeysklar
 
Posts: 8111
Joined: Mon Aug 01, 2016 8:10 pm

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by lvillaautomata on Fri Jul 01, 2022 12:00 am

Adafruit ESP32-S2 TFT Feather - 4MB Flash, 2MB PSRAM, STEMMA QT
PID: 5300

Thank you by the way!

lvillaautomata
 
Posts: 6
Joined: Fri Feb 04, 2022 12:06 am

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by DJDevon3 on Fri Jul 01, 2022 11:13 am

Are you connecting to it through Mu editor or other editor? What do you see in serial (REPL) after hitting reset on the board? Copy and paste any REPL response here please.

DJDevon3
 
Posts: 165
Joined: Wed Mar 06, 2019 11:02 am

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by mikeysklar on Fri Jul 01, 2022 6:44 pm

Any REPL console output as @DJDevon3 requested would be helpful.

You can also try a factor reset as described here:

https://learn.adafruit.com/adafruit-esp ... f2-3107942

Should the above process fail please let us know where.

mikeysklar
 
Posts: 8111
Joined: Mon Aug 01, 2016 8:10 pm

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by lvillaautomata on Tue Jul 05, 2022 12:10 am

DJDevon3 wrote:Are you connecting to it through Mu editor or other editor? What do you see in serial (REPL) after hitting reset on the board? Copy and paste any REPL response here please.


Here's what I see,

Screen Shot 2022-07-04 at 8.56.24 PM.png
Screen Shot 2022-07-04 at 8.56.24 PM.png (495.37 KiB) Viewed 61 times


The screen itself is backlit but don't see anything displayed on it.

lvillaautomata
 
Posts: 6
Joined: Fri Feb 04, 2022 12:06 am

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by lvillaautomata on Tue Jul 05, 2022 12:23 am

mikeysklar wrote:Any REPL console output as @DJDevon3 requested would be helpful.

You can also try a factor reset as described here:

https://learn.adafruit.com/adafruit-esp ... f2-3107942

Should the above process fail please let us know where.


I posted an image of the REPL above.

And what do you mean by let you know where the process fails?

I did the Factory Reset Firmware UF2, reloaded the UF2 but the display is still blank.

lvillaautomata
 
Posts: 6
Joined: Fri Feb 04, 2022 12:06 am

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by mikeysklar on Tue Jul 05, 2022 2:25 pm

Let's have you try running some code on that will use the TFT. The REPL output is might not be going there based on different CircuitPython version defaults.

Code: Select all | TOGGLE FULL SIZE
# SPDX-FileCopyrightText: 2021 Tim C for Adafruit Industries
# SPDX-License-Identifier: MIT
"""
CircuitPython simple text display demo
"""
import board
import terminalio
from adafruit_display_text import bitmap_label

# Update this to change the text displayed.
text = "Hello, World!"
# Update this to change the size of the text displayed. Must be a whole number.
scale = 3

text_area = bitmap_label.Label(terminalio.FONT, text=text, scale=scale)
text_area.x = 10
text_area.y = 10
board.DISPLAY.show(text_area)

while True:
    pass


https://learn.adafruit.com/adafruit-esp ... ay-3111114

mikeysklar
 
Posts: 8111
Joined: Mon Aug 01, 2016 8:10 pm

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by lvillaautomata on Tue Jul 05, 2022 3:13 pm

mikeysklar wrote:Let's have you try running some code on that will use the TFT. The REPL output is might not be going there based on different CircuitPython version defaults.

Code: Select all | TOGGLE FULL SIZE
# SPDX-FileCopyrightText: 2021 Tim C for Adafruit Industries
# SPDX-License-Identifier: MIT
"""
CircuitPython simple text display demo
"""
import board
import terminalio
from adafruit_display_text import bitmap_label

# Update this to change the text displayed.
text = "Hello, World!"
# Update this to change the size of the text displayed. Must be a whole number.
scale = 3

text_area = bitmap_label.Label(terminalio.FONT, text=text, scale=scale)
text_area.x = 10
text_area.y = 10
board.DISPLAY.show(text_area)

while True:
    pass


https://learn.adafruit.com/adafruit-esp ... ay-3111114


I tried all of the test code in the manual. If you look at the same place where that code is located, I SHOULD see the REPL without much effort.

https://learn.adafruit.com/adafruit-esp ... tft-basics

Others have also said that there should be a screen telling me to load a UF2. I am not even seeing that action on my screen.

lvillaautomata
 
Posts: 6
Joined: Fri Feb 04, 2022 12:06 am

Re: TFT NOT WORKING PROPERLY ON ESP32-S

by adafruit2 on Wed Jul 06, 2022 9:04 am

ok you probably have a board with a bad TFT - email support@adafruit for a new feather!

adafruit2
Site Admin
 
Posts: 21078
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.