0

Adafruit Feather 32u4 Fona looses port connection
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Adafruit Feather 32u4 Fona looses port connection

by fgrip on Thu Jan 04, 2018 3:02 pm

I have tried my new Adafruit Feather 32u4 Fona. I have a major problem. I have tried the Example sketch. After about 3 sec after the meny have been written in the serial monitor, it prints:
Code: Select all | TOGGLE FULL SIZE
FONA>
OK

Call Ready

SMS Ready

After that the red LED is blinking irregularly and it feels like it looses the connection with my mac book. When its blinking red the mac cant recognize it as a Adafruit Feather 32u4 Fona. After that the red LED is turned off and i can choose the /dev/cu.usbmodem### (Adafruit Feather 32u4 Fona). So it looses the connection which mean i can hurry to send a letter to do something but after the red LED is blinking or after it don't react to any input from the serial monitor.

Its also happens when i try to upload new code. It looses the port connection.

fgrip
 
Posts: 5
Joined: Thu Jan 04, 2018 3:00 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by adafruit_support_mike on Fri Jan 05, 2018 3:54 am

That sounds like a problem with the supply voltage.

What size LiPo are you using?

adafruit_support_mike
 
Posts: 53022
Joined: Thu Feb 11, 2010 2:51 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by fgrip on Fri Jan 05, 2018 4:14 am


fgrip
 
Posts: 5
Joined: Thu Jan 04, 2018 3:00 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by adafruit_support_mike on Fri Jan 05, 2018 5:30 am

That should be enough. Post a photo showing your hardware and connections please. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 53022
Joined: Thu Feb 11, 2010 2:51 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by fgrip on Fri Jan 05, 2018 7:53 am

Ok!
It seemes that the problem is that the unit crach blinking with the red LED:
Here is the set up
IMG_7115.JPG
IMG_7115.JPG (96.79 KiB) Viewed 389 times

and code:
Code: Select all | TOGGLE FULL SIZE
#include "Adafruit_FONA.h"

#define FONA_RX  9
#define FONA_TX  8
#define FONA_RST 4
#define FONA_RI  7

#include <SoftwareSerial.h>
SoftwareSerial fonaSS = SoftwareSerial(FONA_TX, FONA_RX);
SoftwareSerial *fonaSerial = &fonaSS;

Adafruit_FONA fona = Adafruit_FONA(FONA_RST);

void setup() {
  delay(10000);
  //while (!Serial);
  Serial.begin(115200);

  fonaSerial->begin(4800);
  if (! fona.begin(*fonaSerial)) {
    Serial.println(F("Couldn't find FONA"));
    while (1);
  }


  fona.println("ATS0=1");
  fona.println("AT+VTD=50");
}

void loop() {
    if (fona.available()) {
      Serial.write(fona.read());
    }
  int8_t callstat = fona.getCallStatus();
  if(callstat == 4){
     for(int i=0; i<2; i++){
        fona.println("AT+VTS=\"*\"");
        delay(6000);
     }
     fona.hangUp();
     delay(500);
  }
  delay(500);
}

fgrip
 
Posts: 5
Joined: Thu Jan 04, 2018 3:00 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by adafruit_support_mike on Sat Jan 06, 2018 3:37 am

Everything looks normal there.

Try swapping the USB cable with another one. The cable is a component, and some carry high-speed signals better than others.

adafruit_support_mike
 
Posts: 53022
Joined: Thu Feb 11, 2010 2:51 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by fgrip on Sat Jan 06, 2018 11:19 am

I have tried different USB cabels. Soemtimes it starts and works fine and sometimes is just chrashes. I reboots but craches after a few seconds:
This is the serial output before it crashes:
Code: Select all | TOGGLE FULL SIZE
Attempting to open comm with ATs
   ---> AT
   <---
   ---> AT
   <---
   ---> AT
   <--- AT
   ---> AT
   <--- AT
   ---> ATE0
   <--- ATE0
   ---> ATE0
   <--- OK
   ---> AT+CVHU=0
   <--- OK
   ---> ATI
   <--- SIM800 R13.08

OK

RDY

+CFUN: 1

   ---> AT+GMM
   <--- SIMCOM_SIM800H

OK

+CPIN: READY

   ---> AT+CPMS="SM","SM","SM"
   <--- ERROR

   ---> AT+CPAS
   <--- +CPAS: 2
   ---> AT+CPAS
   <--- +CPAS: 2

   ---> AT+CPAS
   <--- +CPAS: 2

fgrip
 
Posts: 5
Joined: Thu Jan 04, 2018 3:00 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by fgrip on Sat Jan 06, 2018 12:05 pm

Also this:
Code: Select all | TOGGLE FULL SIZE
Exception in thread "AWT-EventQueue-0" java.util.ConcurrentModificationException
   at java.util.LinkedList$LLSpliterator.forEachRemaining(LinkedList.java:1239)
   at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)
   at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471)
   at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151)
   at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174)
   at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
   at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:418)
   at cc.arduino.contributions.libraries.LibrariesIndexer.rescanLibraries(LibrariesIndexer.java:127)
   at processing.app.BaseNoGui.onBoardOrPortChange(BaseNoGui.java:683)
   at processing.app.Base.onBoardOrPortChange(Base.java:1297)
   at processing.app.Editor$SerialMenuListener.actionPerformed(Editor.java:1015)
   at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
   at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
   at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
   at javax.swing.JToggleButton$ToggleButtonModel.setPressed(JToggleButton.java:308)
   at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
   at com.apple.laf.ScreenMenuItemCheckbox.itemStateChanged(ScreenMenuItemCheckbox.java:193)
   at java.awt.CheckboxMenuItem.processItemEvent(CheckboxMenuItem.java:389)
   at java.awt.CheckboxMenuItem.processEvent(CheckboxMenuItem.java:357)
   at java.awt.MenuComponent.dispatchEventImpl(MenuComponent.java:355)
   at java.awt.MenuComponent.dispatchEvent(MenuComponent.java:343)
   at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:761)
   at java.awt.EventQueue.access$500(EventQueue.java:97)
   at java.awt.EventQueue$3.run(EventQueue.java:709)
   at java.awt.EventQueue$3.run(EventQueue.java:703)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
   at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
   at java.awt.EventQueue$4.run(EventQueue.java:731)
   at java.awt.EventQueue$4.run(EventQueue.java:729)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
   at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
   at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
   at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
   at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
   at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

fgrip
 
Posts: 5
Joined: Thu Jan 04, 2018 3:00 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by feirerm on Sat Jan 20, 2018 2:06 pm

Hello everybody,

I have exactly the same problem here on my new feather fona. Except LiPo. I have a 2000mAh

On my board the orange marked part is getting extremely hot.

20180120_185950_resized.jpg
20180120_185950_resized.jpg (895.85 KiB) Viewed 303 times



fgrip wrote:I have tried my new Adafruit Feather 32u4 Fona. I have a major problem. I have tried the Example sketch. After about 3 sec after the meny have been written in the serial monitor, it prints:
Code: Select all | TOGGLE FULL SIZE
FONA>
OK

Call Ready

SMS Ready

After that the red LED is blinking irregularly and it feels like it looses the connection with my mac book. When its blinking red the mac cant recognize it as a Adafruit Feather 32u4 Fona. After that the red LED is turned off and i can choose the /dev/cu.usbmodem### (Adafruit Feather 32u4 Fona). So it looses the connection which mean i can hurry to send a letter to do something but after the red LED is blinking or after it don't react to any input from the serial monitor.

Its also happens when i try to upload new code. It looses the port connection.

feirerm
 
Posts: 2
Joined: Sat Jan 20, 2018 1:56 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by adafruit_support_mike on Sun Jan 21, 2018 4:26 am

That chip is the LiPo charger. Have you used any battery other than the one shown in the photo?

adafruit_support_mike
 
Posts: 53022
Joined: Thu Feb 11, 2010 2:51 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by feirerm on Sun Jan 21, 2018 4:43 am

No. I bought it together with the Feather fona board from adafruit. You think thats the problem?
BR, Mario

feirerm
 
Posts: 2
Joined: Sat Jan 20, 2018 1:56 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by adafruit_support_mike on Sun Jan 21, 2018 4:48 am

It sounds like the LiPo charger has failed, and that would cause problems for the rest of the board.

Send a note containing a link to this thread and your order number to support@adafruit.com. The folks there will get you a replacement.


(#3027)

adafruit_support_mike
 
Posts: 53022
Joined: Thu Feb 11, 2010 2:51 pm

Re: Adafruit Feather 32u4 Fona looses port connection

by forrestone on Mon Feb 05, 2018 8:16 am

Hi,
I have a similar issue with my Feather FONA.
That component is getting very hot.
And now I cannot even interact anymore properly with the FONA through the FONA-test sketch...
https://youtu.be/LrX_Va98HPg

forrestone
 
Posts: 7
Joined: Mon Feb 05, 2018 8:15 am

Please be positive and constructive with your questions and comments.