0

Feather running slower on battery?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Feather running slower on battery?

by terranjerry on Mon Jan 15, 2018 1:08 am

I have a very simple sketch I wrote for my Feather 32u4 basic proto board with an OLED display attached.
I have observed that the "loop()" code when running on the USB cable runs at a certain rate such that when I press one of the buttons on the OLED board, I generally get a response within about 2 seconds as indicated on the display.

When I unplug the USB cable and run off the connected pkcell (3.7V 500 mAh) battery, (same code) it runs considerably slower.
For example, the same button press that took about 2 seconds to receive a response when on the USB cable now on the battery it may take several seconds - up to 5 or 6.

I was just wondering, does the Feather slow down when on battery power or could something else be going on that makes it take longer to respond?
By the way, my voltage shown by the Feather for the battery is 4.23 v

Thanks for any shared thoughts on this.
Jerry

terranjerry
 
Posts: 29
Joined: Tue Feb 11, 2014 1:39 pm

Re: Feather running slower on battery?

by adafruit_support_mike on Mon Jan 15, 2018 5:31 am

No, the microcontroller shouldn't slow down.

In fact, the microcontroller shouldn't notice any difference.. it runs from the output of the onboard 3.3v voltage regulator, and that should be the same whether you use USB power or a LiPo.

Which OLED are you using?

adafruit_support_mike
 
Posts: 47746
Joined: Thu Feb 11, 2010 2:51 pm

Re: Feather running slower on battery?

by terranjerry on Wed Jan 17, 2018 3:38 pm

Hello Mike,
Thanks for writing back. I am running the OLED 128x32 specifically designed for use on the Feather boards.
Later, after I had written this question up, I found that it seemed to be running at normal speed again on the battery. So, I'm not sure what was going on for that brief period.
I would have to (at this point) toss it up to some type of coding problem. I'll keep an eye on it and report back if I see further slow-downs like the one I mentioned.

By the way, thanks for great products - both the Feather basic proto and the OLED that attaches to it are very cool and fun to program.

Kind regards,
Jerry

terranjerry
 
Posts: 29
Joined: Tue Feb 11, 2014 1:39 pm

Re: Feather running slower on battery?

by adafruit_support_mike on Fri Jan 19, 2018 3:26 am

Ah.. things like that happen sometimes. It could have been a glitch in the signal timing or something. We usually call them 'gremlins' and move on.

Glad to hear things are working though. Happy hacking!

adafruit_support_mike
 
Posts: 47746
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.