Featherboard not displaying any images
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Featherboard not displaying any images

by Ohno on Sat Feb 16, 2019 4:02 pm

I've recently started working on the "Thermal Camera with Display" Project and while going through it, everything was going fine (installing the updated libraries & HUZZAH ide) until I tried running the code. When I uploaded the thermal_camera_interpolate sketch, it would upload but the featherboard would display a white screen, and the serial monitor listed an array of -0.25's rather than detecting any heat.

Then I checked to see if the thermal camera was working using the amg88xx_test and it returned a Thermistor Temperature of -127.94 C. I've tried to do some research in order to see if there was anything else that I've missed but it kept leading up to the same case of the wires not being soldered correctly. The wires that i'm using are jumper wires rather than the 30AWG wires, and neither is the solder that I'm using is the same as the one listed in the overview page of the thermal camera. Other than that, i'm using the Adafruit HUZZAH which is already assembled (The reason why i'm using jumper wires instead).

The setup for the circuit is the exact same as the one in the thermal camera page, and the slide switch does work properly, One last issue is that the Port that i'm getting whenever I connect the HUZZAH to my device is that it shows up as COM6 instead of "SiLabs".

Here are all the things I've tried/have done to make my thermal camera work:

- Set up the circuit properly
- Use different jumper wires and solder
- Install the libraries & driver necessary to run the camerar (CP2104, AMG8833, Adafruit IL9341, Adafruit GFX Library, Thermal Camera Interpolate Sketch)
- I'm using the ESP32 Dev Module, I've tried using stable ver. of ESP32 before that.
- I've tried to test both my featherboard and my thermal camera, both tests failing.
- Running the whole circuit on its own without it plugged into my device.

If anyone knows of something that I may have not done properly it would be greatly appreciated if you could notify me of it. Thanks!

Posts: 1
Joined: Sat Feb 16, 2019 3:35 pm

Please be positive and constructive with your questions and comments.