0

Bug in 52832 stack introduced in 11.1 and up ??
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Bug in 52832 stack introduced in 11.1 and up ??

by jps2000 on Thu Aug 22, 2019 4:05 am

Observed with Feather nrf52832 Arduino IDE 1.8.5
The bleuart example works fine with Bluefruit52 release 10.0, 11.0 ( blue led flashing, advertising).
However, upgrading to 11.1, 12.0 fails completely. Blue led is off, no advertising
it seem to continuously boot; Red LED is flashing

That is what debug1 says:

Bluefruit52 BLEUART Example
---------------------------

[CFG ] SoftDevice's RAM requires: 0x20002FA0
Bluefruit52 BLEUART Example
---------------------------

[CFG ] SoftDevice's RAM requires: 0x20002FA0
Bluefruit52 BLEUART Example
---------------------------

[CFG ] SoftDevice's RAM requires: 0x20002FA0
Bluefruit52 BLEUART Example

I noticed a short low spike on the DFU pin.

???
pls repair

jps2000
 
Posts: 449
Joined: Fri Jun 02, 2017 4:12 pm

Re: Bug in 52832 stack introduced in 11.1 and up ??

by jps2000 on Fri Aug 23, 2019 2:12 am

Just tested the fresh 0.13.0 version.
BLEUART example is NOT WORKING with a feather 52832.
( No flashing blue LED)
Latest working was 0.11.0 !

jps2000
 
Posts: 449
Joined: Fri Jun 02, 2017 4:12 pm

Re: Bug in 52832 stack introduced in 11.1 and up ??

by jps2000 on Sat Aug 24, 2019 3:51 am

can somebody try to verify it please?

jps2000
 
Posts: 449
Joined: Fri Jun 02, 2017 4:12 pm

Re: Bug in 52832 stack introduced in 11.1 and up ??

by jps2000 on Sat Aug 31, 2019 4:02 am

With Arduino IDE 1.8.9 it seemed ok
Not clear why

jps2000
 
Posts: 449
Joined: Fri Jun 02, 2017 4:12 pm

Please be positive and constructive with your questions and comments.