0

CPX stopped working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

CPX stopped working

by goodbow on Sun Feb 17, 2019 12:09 pm

Hi

I purchased Adabox 008 directly from Adafruit before Christmas to give to my children as a Christmas gift. The box is great and we have had fun starting to explore what we can build with it. However, yesterday the Circuit Playground Express stopped working - when I plug it into my Windows 10 laptop via USB the green LED comes on but nothing else happens and the laptop doesn't see it as an external drive. I have tried numerous different USB cables and the same problem arises so it isn't a cabling issue. I have also tried plugging it into other laptops and this doesn't work either. I have also tried single pressing and double pressing the reset button, but to no avail. It appears to have stopped functioning altogether.

Is it covered by a warranty, and if so would Adafruit ship a replacement to me please? Or can you suggest something I might be able to do to kickstart it working again?

My order confirmation from December was 1910397-9616607614.

Thanks

Will
Attachments
CPX.jpg
CPX.jpg (190.45 KiB) Viewed 127 times

goodbow
 
Posts: 6
Joined: Sun Feb 17, 2019 12:04 pm

Re: CPX stopped working

by adafruit_support_mike on Tue Feb 19, 2019 3:30 am

Verify your USB cable by using it to connect some other, known-working device to the computer.

There's a plague of charge-only cables out there, with USB connectors at both ends but no wires for the data signals. They're common enough that just swapping cables doesn't prove anything.. it's become normal for people to say they had to try three or four cables before finding one that worked. You need the true positive of a working connection to rule out the false negative of a charge-only cable.

adafruit_support_mike
 
Posts: 55974
Joined: Thu Feb 11, 2010 2:51 pm

Re: CPX stopped working

by goodbow on Tue Feb 19, 2019 6:54 am

Thanks for your response Mike. But it is definitely not a cable issue. I temporarily borrowed another CPX from a friend to verify cables and all that I tried worked fine with the borrowed CPX. So the cable is not the problem.

Will

goodbow
 
Posts: 6
Joined: Sun Feb 17, 2019 12:04 pm

Re: CPX stopped working

by goodbow on Thu Feb 21, 2019 6:17 pm

Hi Mike.

I haven’t heard anything back from you following my last post. I’d be grateful if you could reply please. I was told when I emailed AdaFruit support that my problem would be addressed here and a replacement issued if it couldn’t be fixed. I’m keen to get this resolved or a replacement sent out to me so I can get back to coding with my kids.

Thanks

Will

goodbow
 
Posts: 6
Joined: Sun Feb 17, 2019 12:04 pm

Re: CPX stopped working

by adafruit_support_carter on Mon Feb 25, 2019 6:35 pm

Thanks for verifying the USB cable. It's unfortunate you can't double press reset and get it back into bootloader mode. We can quite often recover boards once there.

It just stopped working? Do you know what the last thing you were doing was? What was the last program you successfully uploaded?

adafruit_support_carter
 
Posts: 9887
Joined: Tue Nov 29, 2016 2:45 pm

Re: CPX stopped working

by goodbow on Mon Feb 25, 2019 6:40 pm

Hi Carter

We were building the Stumble Bot from Adabox 008. We had finished building the robot and had uploaded the code and tested it. It was working fine and then it just stopped working.

Will

goodbow
 
Posts: 6
Joined: Sun Feb 17, 2019 12:04 pm

Re: CPX stopped working

by adafruit_support_carter on Mon Feb 25, 2019 6:46 pm

So it was connected to Crickit and motor and power and was stumbling along and then.....no stumble bot :(

When you try the reset presses to get into bootloader, do the ring of NeoPixels do anything? And you are doing all of this with the CPX removed from the Crickit?

adafruit_support_carter
 
Posts: 9887
Joined: Tue Nov 29, 2016 2:45 pm

Re: CPX stopped working

by goodbow on Mon Feb 25, 2019 6:59 pm

No it doesn’t do anything. Apart from the green light staying lit permanently once its connected to power, it doesn’t react in any way to button presses, resets or to being plugged into a laptop via USB.

And no, I’ve removed it from the Crickit to test it, and it is still not working on its own. The Crickit is working fine though as I tried a friend’s CPX in it. The issue is only with the CPX.

Will

goodbow
 
Posts: 6
Joined: Sun Feb 17, 2019 12:04 pm

Re: CPX stopped working

by adafruit_support_carter on Mon Feb 25, 2019 9:33 pm

OK, we can replace it this go round. Since it was initially working, it may have been something related to the motor usage and associated power. But it sounds like you were just following the guide. If it happens again, see if you can correlate the failure to something.

Send an email to support@adafruit.com with a link to this thread (order number is in first post) and they can send you a replacement CPX (PID 3333).

adafruit_support_carter
 
Posts: 9887
Joined: Tue Nov 29, 2016 2:45 pm

Re: CPX stopped working

by goodbow on Tue Feb 26, 2019 4:21 am

Ok, I’ll do that. Thank you for your help.

Will

goodbow
 
Posts: 6
Joined: Sun Feb 17, 2019 12:04 pm

Please be positive and constructive with your questions and comments.