0

circuitpy drive not appearing
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

circuitpy drive not appearing

by Phillip_ on Sat Sep 11, 2021 1:37 am

I plugged in the circuit playground express for the first time. The operating system sent the message "setting up your hardware" then a minute or so later the message "your hardware is ready to use" or something similar appeared and then the colored lights on the board started flashing in a circular pattern. I went to the "This PC" screen and there is no circuitpy drive, only Acer C and McAfe. vaults. I opened the Mu editor and got the message that I have to connect my device. The "Welcome to CircuitPython" instructions say to be sure that the circuitpy drive is recognized, but give no advice if it is not recognized. There is almost nothing in the troubleshooting section on this problem. I don't see any way to disable the McAfe. anti-virus software, but I was able to disable the firewall. I rebooted the computer with the firewall disabled and plugged in the circuit playground express board. The circuitpy drive still does not appear. I have an Acer Aspire laptop, running one of the most common operating systems, 64 bit windows 10 home edition, with anti-virus software from one of the most widely used vendors, McAfe.. Any suggestions on how to get the circuitpy drive to be recognized?

Phillip_
 
Posts: 7
Joined: Sat Sep 04, 2021 8:54 pm

Re: circuitpy drive not appearing

by dastels on Sat Sep 11, 2021 11:12 am


dastels
 
Posts: 7253
Joined: Tue Oct 20, 2015 3:22 pm

Re: circuitpy drive not appearing

by Phillip_ on Mon Sep 13, 2021 6:19 pm

I opened the "This PC" screen which shows the drives. Then plugged in the playground express board. The colored lights began the circular pattern and there was no circuit playground drive. I decided to press the reset button on the board. Suddenly the CPLAYBOOT(D:) drive appeared and the lights turned solid green. I opened the Mu editor and still get the message: "Could not find an attached circuitpython device" I quit and reloaded Mu, plugged in and reset the board several times. Mu still does not recognize the circuitpython board.

Phillip_
 
Posts: 7
Joined: Sat Sep 04, 2021 8:54 pm

Re: circuitpy drive not appearing

by Phillip_ on Mon Sep 13, 2021 7:04 pm

I reread the "Welcome to Circuit Python" instructions and realized that I'm seeing the bootloader drive and not the circuitpy drive. That's why Mu doesn't recognize the device. So, I followed the instructions and updated the circuit python software on the board and the bootloader drive changed to the circuitpy drive and Mu now recognizes the device. Had I done this before loading Mu then I would have had no problem. I think this is a serious flaw in the order of the instructions. Installing Circuit Python should be done before Installing the Mu Editor, not afterward. Until circuitpython is installed on the board the circuitpy drive will not appear and the Mu editor will not recognize the device. These appear to be problems, but if fact are the result of things not being done in the proper sequence.

Phillip_
 
Posts: 7
Joined: Sat Sep 04, 2021 8:54 pm

Re: circuitpy drive not appearing

by dastels on Mon Sep 13, 2021 9:09 pm

It seems that your board did not have CircuitPython installed. That didn't occur to me since you mentioned having Mu installed so I figured you'd gone through the entirety of the guide. It might make more sense to install CircuitPython at the start.

Dave

dastels
 
Posts: 7253
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.