0

Regarding pairing of 2 bluefruit modules
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Regarding pairing of 2 bluefruit modules

by sheeyam on Thu Apr 05, 2018 12:54 am

is it possible to connect and pair 2 Adafruit Bluefruit LE uart friend modules using 2 circuit playground express boards .?

sheeyam
 
Posts: 6
Joined: Tue Mar 06, 2018 1:11 am

Re: Regarding pairing of 2 bluefruit modules

by adafruit_support_mike on Thu Apr 05, 2018 1:38 am

Nope.

Bluetooth works roughly the same way as a USB cable, but without the cable. It assumes there's a central device that talks to one or more peripherals, but doesn't allow peripherals to talk to each other. That arrangement puts most of the cost and complexity in the central device, leaving the peripherals to be smaller, simpler, less expensive, etc.

The BLE UART Friend only works as a peripheral. Aside from some low-level error checking, one peripheral doesn't know any other peripheral even exists.

We normally use packet radio modules for peer-to-peer wireless communication between microcontrollers:

https://learn.adafruit.com/search?q=packet%20radio

but those communicate with a microcontroller through the SPI interface. The Circuit Playground's SPI interface isn't broken out to the pads at the edge of the board, so there's no easy way to connect a packet radio module to a CPX.

I'm afraid we don't have any good solutions for radio communication between those boards.

adafruit_support_mike
 
Posts: 53119
Joined: Thu Feb 11, 2010 2:51 pm

Re: Regarding pairing of 2 bluefruit modules

by sheeyam on Thu Apr 05, 2018 3:09 am

I have connected and paired 2 HC-05 Bluetooth modules using circuit playground express boards.I am able to send and receive data's between these 2 boards via Bluetooth modules.
The problem is that the data which i am sending from one end is recieved as a special character in the other end because of which I am unable to proceed further for controlling applications. I tried with different baud rates,but the issue still prevails.
What could be the reason behind this.? How to solve this issue?

sheeyam
 
Posts: 6
Joined: Tue Mar 06, 2018 1:11 am

Please be positive and constructive with your questions and comments.