Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Incorrect Drivers/CPlay express other devices
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Incorrect Drivers/CPlay express other devices

by vicarij1 on Thu Mar 12, 2020 2:38 pm

Hello!

I'm running windows 10 and I'm attempting to use the Adafruit Circuit Playground express with the Arduino IDE. When I plug in the device, in device manager it shows "CPlay Express" under the Other devices tab. Under the com ports tab, there is no extra information, only that is recognizes COM3.

In properties under the CPlay Express device it shows:

"The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver."

When I attempt to update the driver automatically, it says that no drivers could be found. Arduino will not upload a sketch to this device. I've been trying to troubleshoot this issue for a week now and haven't found any solution. Can anyone help me with this?

vicarij1
 
Posts: 1
Joined: Thu Mar 12, 2020 2:34 pm

Re: Incorrect Drivers/CPlay express other devices

by adafruit_support_carter on Fri Mar 13, 2020 6:30 pm

Did you try the driver install from here?
https://learn.adafruit.com/adafruit-cir ... stallation

adafruit_support_carter
 
Posts: 17149
Joined: Tue Nov 29, 2016 2:45 pm

Re: Incorrect Drivers/CPlay express other devices

by smd58tex on Sun Apr 19, 2020 3:45 pm

I'm having similar issues. And the driver should not be required on windows 10, according to the page you linked.

smd58tex
 
Posts: 6
Joined: Mon Aug 06, 2018 1:53 am

Re: Incorrect Drivers/CPlay express other devices

by adafruit_support_carter on Mon Apr 20, 2020 10:29 am

@smd58tex Please start a new thread for your issue.

adafruit_support_carter
 
Posts: 17149
Joined: Tue Nov 29, 2016 2:45 pm

Re: Incorrect Drivers/CPlay express other devices

by danhalbert on Mon Apr 20, 2020 2:35 pm

Is the board listed with a yellow triangle? A screenshot from Device Manager might be helpful.

Try uninstalling any existing driver for the board. The Arduino package will install a driver even on Windows 10, which is not necessarily a good idea. With the board plugged in, go into Device Manager, right-click on the device, choose Uninstall..., and uninstall with the box checked that removes the software.

danhalbert
 
Posts: 2138
Joined: Tue Aug 08, 2017 12:37 pm

Please be positive and constructive with your questions and comments.