Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

All red neopixel state?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

All red neopixel state?

by m_wayne_davis on Fri Jun 12, 2020 6:08 pm

I was using my CPX in the Arduino IDE as normal. Then, after uploading a file, the CPX went into a mode with all red neopixels and fast flickering LED13. The on LED is still green. Now the IDE doesn't see the board. Pressing or double pressing reset does nothing to change anything. Tried another USB cable, same result. Is it bricked?

Thanks.

m_wayne_davis
 
Posts: 3
Joined: Fri Jun 12, 2020 10:44 am

Re: All red neopixel state?

by adafruit_support_carter on Mon Jun 15, 2020 5:23 pm

What was the file you were uploading?

adafruit_support_carter
 
Posts: 16820
Joined: Tue Nov 29, 2016 2:45 pm

Re: All red neopixel state?

by m_wayne_davis on Mon Jun 15, 2020 5:34 pm

"Talk_US_Clock" from the Circuit playground examples folder.
I uncommented some of the const progmem lines that had been commented.
See upload

Thanks
Attachments
Talk_US_Clock.ino
(21.39 KiB) Downloaded 2 times

m_wayne_davis
 
Posts: 3
Joined: Fri Jun 12, 2020 10:44 am

Re: All red neopixel state?

by m_wayne_davis on Tue Jun 30, 2020 6:40 pm

No responses yet to this question, so I'm not sure if there's anything that can be done. Is the CPX toast?

m_wayne_davis
 
Posts: 3
Joined: Fri Jun 12, 2020 10:44 am

Re: All red neopixel state?

by adafruit_support_carter on Tue Jun 30, 2020 7:34 pm

Then, after uploading a file, the CPX went into a mode with all red neopixels and fast flickering LED13.

This indicates a USB error. The bootloader must still be at least somewhat intact, as that is what is driving the NeoPixels and the blinking LED13.

Trying other USB cables and also maybe other USB ports is what usually fixes this. Even though you've done that, maybe double verify the USB cables are good by using them with something else.

Was anything external ever attached to the CPX? Like to the pads, etc?

adafruit_support_carter
 
Posts: 16820
Joined: Tue Nov 29, 2016 2:45 pm

Re: All red neopixel state?

by jhuertaz2 on Tue Aug 04, 2020 3:56 pm

This is happening to me right now. I had a servo connected to A1, GND, and VOut for about 2 minutes and then it made the CPB disconnect from the computer. I disconnected the servo from the board and plugged the usb back into the computer. The CPB turns on but it only lasts about 30 seconds before it overheats and goes into all Red Neopixel state. I don't know what to do. For those 30 seconds I am able to go into the CPB and see all the files saved on it.

jhuertaz2
 
Posts: 4
Joined: Tue Aug 04, 2020 3:51 pm

Re: All red neopixel state?

by adafruit_support_carter on Tue Aug 04, 2020 4:01 pm

@jhuertaz2 Please start a new thread for your issue.

adafruit_support_carter
 
Posts: 16820
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.