Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Can't get graphicstest example to work
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Can't get graphicstest example to work

by petespaco on Sat Jun 27, 2020 1:24 pm

Hello.
I have the CPX and a GIZMO.
Previously, I had loaded one of the UF2 examples and it worked as expected. But I want to use the Arduino IDE (as I have mentioned in previous posts), so---
Today I went through the process of making sure I have the correct "Arduino" libraries loaded, for the second time.
The uploading of the graphicstest example sketch went normally with me making no changes to the code. However, all that happened is that the backlight for the TFT flashes a couple of times and then all of the neopixels came on very bright and all white. No information on the display at all.
So, I then looked at the code and saw a whole bunch of "use this initializer---" statements and realized that the default setting (for the 1.8" display was not right for the GIZMO.
I measured it and it appeared to be 1.4", so I commented out the 1.8 and uncommented the 1.4.
Same result.
Then I went back to your tutorial and found that it's 1.54".
So, I chose this one:
// OR use this initializer (uncomment) if using a 1.3" or 1.54" 240x240 TFT:
//tft.init(240, 240); // Init ST7789 240x240
and uncommented it.
Now I get the error:
'class Adafruit_ST7735' has no member named 'init'; did you mean 'initB'?
Well I tried that and still no luck. ( I has also tried initR and that didn't work either.
Now I get:
no matching function for call to 'Adafruit_ST7735::initB(int, int)'
I thought I was getting close, but still no luck.

Pete Stanaitis
-------------------

petespaco
 
Posts: 96
Joined: Thu Apr 19, 2012 7:53 pm
Location: west central wisconsin

Re: Can't get graphicstest example to work

by petespaco on Sat Jun 27, 2020 6:48 pm

Well, now for some GOOD news:
I just looked at the examples again and found one that was specific to the GIZMO (but it wasn’t the one recommended in your tutorial).
It is called "graphicstest_tft_gizmo"
I loaded it and it still didn’t work, but there were a couple of options in the code and, after selecting the one the was NOT recommended, it works!!!
Now, maybe I have some hope of being able to actually program the CPX with an Adafruit-approved display (GIZMO) one of these days.

Thank you for your patience with me,
Pete Stanaitis
--------------------

petespaco
 
Posts: 96
Joined: Thu Apr 19, 2012 7:53 pm
Location: west central wisconsin

Re: Can't get graphicstest example to work

by adafruit_support_carter on Sat Jul 18, 2020 5:52 pm

Glad you figured it out.

What guide were you following? Just checked here:
https://learn.adafruit.com/adafruit-tft ... aries-test
and it's calling out the graphicstest_tft_gizmo example.

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Can't get graphicstest example to work

by petespaco on Sun Jul 19, 2020 10:46 am

It has been a while since I got it going. But I think my error was that I chose the "graphicstest" example when I first looked at the list of choices without noticing the suffix "gizmo" on an option farther down. I also, at that time wasn't smart enough to realize that "ST7735 and ST7789" sorta means TFT stuff.

petespaco
 
Posts: 96
Joined: Thu Apr 19, 2012 7:53 pm
Location: west central wisconsin

Please be positive and constructive with your questions and comments.