Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

CPX and external neopixels getting clicking sound
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

CPX and external neopixels getting clicking sound

by lerxst151 on Sat Jul 04, 2020 5:41 pm

I connected a 12 Neopixel ring to my CPX and did just a basic MakeCode for the ring connected on A0.
I've set the external ring to RGB+W.

When I do a show of any of the animations to the external ring I get a clicking sound while the animation is running.
I do not get the clicking sound if I run the animations on the internal neopixel ring on the CPX.

Is this normal? If so, how do I turn the clicking off?

lerxst151
 
Posts: 24
Joined: Mon Apr 02, 2018 3:19 pm

Re: CPX and external neopixels getting clicking sound

by dastels on Sat Jul 04, 2020 5:52 pm

A0 drives the speaker as well. You can disable the speaker amplifier using output #11, as per the CPX tutorial guide:

The amplifier is connected to the true analog output A0 pin -- this pin is also available on one of the connection pads in the lower right. You can tell it's the analog output pin because of the squiggly symbol.

If you do not want the internal speaker to make noise, you can turn it off using the shutdown control on pin #11


I'm not sure how to access that in Makecode... it doesn't seem to be one of the digital write pin options.

Dave

dastels
 
Posts: 3403
Joined: Tue Oct 20, 2015 3:22 pm

Re: CPX and external neopixels getting clicking sound

by lerxst151 on Sat Jul 04, 2020 5:58 pm

Ahh ok.. i guess I missed that.

Thanks for the quick reply.

lerxst151
 
Posts: 24
Joined: Mon Apr 02, 2018 3:19 pm

Please be positive and constructive with your questions and comments.