Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Circuit Playground Library - New Dependencies
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Circuit Playground Library - New Dependencies

by finson on Tue Jul 28, 2020 8:52 pm

I have the Circuit Playground library installed, though I don't use it. Lately I have been getting messages from the library manager that it needs updating. However, when I go to do that, I get a long list of dependencies that need to be installed. Since the library description specifically says that it is an "All in one library to control Adafruit's Circuit Playground board. Requires no other dependencies ..." I'm inclined to think there's something wrong in the library properties somewhere.

Mac OS 10.15.6. Arduino version 1.8.12. Installed Circuit Playground Library version 1.10.4. Library manager wants me to upgrade library to 1.11.0. It says I need 14 new libraries to support the upgrade. This seems like an error in the manager; is there something I'm overlooking?

Screen Shot 2020-07-28 at 5.38.24 PM.png
Screen Shot 2020-07-28 at 5.38.24 PM.png (409.15 KiB) Viewed 53 times

finson
 
Posts: 23
Joined: Sun Dec 30, 2012 2:49 pm
Location: Seattle, WA, USA

Re: Circuit Playground Library - New Dependencies

by finson on Sun Aug 09, 2020 6:16 pm

Well, since this has been viewed 25 times and there haven't been any "me too" comments, I assume that there is something odd about how I installed the library and so I went ahead and updated my system and added all the dependencies.

finson
 
Posts: 23
Joined: Sun Dec 30, 2012 2:49 pm
Location: Seattle, WA, USA

Re: Circuit Playground Library - New Dependencies

by finson on Sun Aug 09, 2020 6:33 pm

PS. When I did the update, I got messages from the library manager that four libraries were already installed: Adafruit GFX, Adafruit BUSIO, SD, and Mouse.

The first two were listed in the original error message required but not installed.

The second two were not listed as being needed, so it's not clear to me why it's noteworthy that they are "already installed."

I do still think that the dependencies information provided by the Circuit Playground library to the library manager is a little mixed up, but the immediate issue was resolved on my system when I went ahead and did the update.

finson
 
Posts: 23
Joined: Sun Dec 30, 2012 2:49 pm
Location: Seattle, WA, USA

Re: Circuit Playground Library - New Dependencies

by siddacious on Mon Aug 10, 2020 12:36 am

Hi! Apologies for not seeing this sooner.

The dependencies that you're being told need to be installed/updated are required to run the examples, however they should not be necessary to use the library itself.

It's not ideal, but until Aruino provides a way to differentiate between deps for examples vs the library itself, this is the hammer we have.

siddacious
 
Posts: 297
Joined: Fri Apr 21, 2017 3:09 pm

Please be positive and constructive with your questions and comments.