0

No circuitpy drive shows up
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

No circuitpy drive shows up

by lamachine on Thu Mar 18, 2021 5:50 pm

I was struggling with a 52840 express, and while waiting for support, I started up the the cpe I got with my order. It boots fine but does not show up as a drive or to Mu. When I double click it, I get (inconsistently) the CPLAYBOOT drive. I have replaced the UF2 file several time with either the link it the tutorials OR with the latest one. It does not reboot when it finishes loading the file. When I hit reset, it boots into the circular pattern on neo's and chirps when I press D4 button.

I tried different ports and different cables in spite of the fact that the cables work fine for the Feather NRF52840 and the Feather M4.

lamachine
 
Posts: 35
Joined: Thu Feb 25, 2021 5:01 pm

Re: No circuitpy drive shows up

by dastels on Thu Mar 18, 2021 6:49 pm

Double check that you are loading CircuitPython for the CircuitPlayground Express.

Dave

dastels
 
Posts: 6786
Joined: Tue Oct 20, 2015 3:22 pm

Re: No circuitpy drive shows up

by lamachine on Thu Mar 18, 2021 8:01 pm

Dave,

Thanks for the quick reply. I have tried:

adafruit-circuitpython-circuitplayground_bluefruit-en_US-6.1.0.uf2
Bluefruit_Playground_CPB.uf2
FIRMATA_2018-2-19.uf2

lamachine
 
Posts: 35
Joined: Thu Feb 25, 2021 5:01 pm

Re: No circuitpy drive shows up

by dastels on Thu Mar 18, 2021 8:36 pm

If you do indeed have a CircuitPlayground Express (https://learn.adafruit.com/adafruit-circuit-playground-express) then you should be using a UF2 from https://circuitpython.org/board/circuitplayground_express/, probably 6.1.0.

The build of CircuitPython has to exactly match the board you are putting it on.

Dave

dastels
 
Posts: 6786
Joined: Tue Oct 20, 2015 3:22 pm

Re: No circuitpy drive shows up

by lamachine on Fri Mar 19, 2021 1:02 pm

WOW, what a newb mistake. I spent so much time trying to figure out what was wrong with the software, and it was an EBCAK (Error Between Chair and Keyboard). Thanks so much.

Know anything about bluetooth? Or can you find my mistake here? https://forums.adafruit.com/viewtopic.php?f=53&t=176692

Excellent support! Please consider this closed.

Bob O

lamachine
 
Posts: 35
Joined: Thu Feb 25, 2021 5:01 pm

Please be positive and constructive with your questions and comments.