0

Another Adabox 007 Gemma MO Request for help
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Another Adabox 007 Gemma MO Request for help

by TopherGopher on Sun May 13, 2018 12:59 am

I'm trying to get the UV ink reader file on my Gemma MO, but the .uf2 file never seems to overwrite what is on the board. I've double clicked on the board button, but the red light never pulses red. Any help would be greatly appreciated. Thanks

TopherGopher
 
Posts: 4
Joined: Tue Jan 26, 2016 9:42 pm

Re: Another Adabox 007 Gemma MO Request for help

by adafruit_support_mike on Mon May 14, 2018 1:53 am

Does the Gemma show up as a small USB drive when you connect it to your computer?

adafruit_support_mike
 
Posts: 51973
Joined: Thu Feb 11, 2010 2:51 pm

Re: Another Adabox 007 Gemma MO Request for help

by TopherGopher on Mon May 14, 2018 8:44 am

It does. I'm able to get it into GEMMABOOT as a drive. I'm also able to see the drive listed as CIRCUITPY when I first plug it in and can adjust the Main.py code. This will work for me, I was just hoping to use the Make Code uf2 file.

I've tried multiple uf2 files, one of which was just a simple blink sketch, but it didn't work either. I'll run through some more tests to see if there is an issue with the capacitive pad, the outputs, or something else.

TopherGopher
 
Posts: 4
Joined: Tue Jan 26, 2016 9:42 pm

Re: Another Adabox 007 Gemma MO Request for help

by TopherGopher on Mon May 14, 2018 7:52 pm

After more tests, it appears the board is working perfectly even with Make Code. The IR light, on the other hand, is not.
I guess I'll just have to add that to my next order.

TopherGopher
 
Posts: 4
Joined: Tue Jan 26, 2016 9:42 pm

Re: Another Adabox 007 Gemma MO Request for help

by adafruit_support_mike on Tue May 15, 2018 3:15 am

Post a photo showing how you have the UV LED connected to the Gemma. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 51973
Joined: Thu Feb 11, 2010 2:51 pm

Re: Another Adabox 007 Gemma MO Request for help

by TopherGopher on Tue May 15, 2018 9:57 am

I was able to get it working. Typical user error. Thanks for the help Mike.

(slowly bows head in shame and walks away)

TopherGopher
 
Posts: 4
Joined: Tue Jan 26, 2016 9:42 pm

Re: Another Adabox 007 Gemma MO Request for help

by adafruit_support_mike on Wed May 16, 2018 12:16 am

Nah.. mistakes happen all the time.

The idea that someone has an idea, sits down and builds it, and everything works on the first try is a myth. Most projects only work because the builder ran out of ways to fail.

Thing is, we get as many one-more-chances as we're willing to take. The more we can eliminate the (unproductive) stigma associated with mistakes and failure, the healthier we'll all be as Makers.

Glad to hear you got things working. Happy hacking!

adafruit_support_mike
 
Posts: 51973
Joined: Thu Feb 11, 2010 2:51 pm

Re: Another Adabox 007 Gemma MO Request for help

by EqualDemo on Sun Aug 12, 2018 4:31 pm

TopherGopher wrote:I was able to get it working. Typical user error. Thanks for the help Mike.

(slowly bows head in shame and walks away)



Would you mind sharing what the user error was? I may be doing the same thing wrong. I've been working on the TVZapper, but can't get the IR LED to flash, just the onboard ones are flashing all different colors. I've confirmed the IR LED is good because when I power it from a battery directly connected, it lights up.

EqualDemo
 
Posts: 13
Joined: Tue Jun 26, 2018 10:30 am

Re: Another Adabox 007 Gemma MO Request for help

by adafruit_support_mike on Mon Aug 13, 2018 12:24 am

Post a photo showing your hardware and connections and we'll take a look. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 51973
Joined: Thu Feb 11, 2010 2:51 pm

Re: Another Adabox 007 Gemma MO Request for help

by EqualDemo on Mon Aug 13, 2018 11:36 am

Hi Mike -

Here's the current arrangement. I have tried flipping the LED legs around with no luck, and please note that the transistor included with the kit broke- a leg came off after I moved it too many times, so I replaced it with an NPN bipolar transistor. I don't know if that's part of the problem. (picture is blurry on the transistor, but the flat side is facing up in that photo)
gemma.jpg
gemma.jpg (822.36 KiB) Viewed 30 times

Thanks for taking a look!

EqualDemo
 
Posts: 13
Joined: Tue Jun 26, 2018 10:30 am

Re: Another Adabox 007 Gemma MO Request for help

by EqualDemo on Mon Aug 13, 2018 12:00 pm

I think I just realized that I had the transistor legs swapped, so I got a new NPN bipolar transistor and switched the legs.

Still no IR led though.

gemma2.jpg
gemma2.jpg (833.07 KiB) Viewed 28 times

EqualDemo
 
Posts: 13
Joined: Tue Jun 26, 2018 10:30 am

Re: Another Adabox 007 Gemma MO Request for help

by adafruit_support_mike on Mon Aug 13, 2018 2:56 pm

In the most recent photo above, the IR LED is connected backwards. If you look inside the envelope, the anvil (the wide part that holds the actual LED) needs to connect to GND.

adafruit_support_mike
 
Posts: 51973
Joined: Thu Feb 11, 2010 2:51 pm

Re: Another Adabox 007 Gemma MO Request for help

by EqualDemo on Mon Aug 13, 2018 4:49 pm

Thank you- I switched the LED around per your instruction, but I'm not getting any light out of it when I look at it with my phone's camera. The onboard pink led stopped flashing like it was before though. Now I get green and blue onboard leds.

Any other things I should try? Appreciate the help.

EqualDemo
 
Posts: 13
Joined: Tue Jun 26, 2018 10:30 am

Re: Another Adabox 007 Gemma MO Request for help

by adafruit_support_mike on Tue Aug 14, 2018 12:48 am

Check the voltage at the point where the LED's GND leg connects to the transistor and see if that changes while the LED is supposed to be turned on.

adafruit_support_mike
 
Posts: 51973
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.