0

PyPortal issue - no USB drive for circuit python or uf2 prog
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

PyPortal issue - no USB drive for circuit python or uf2 prog

by paks on Tue Apr 02, 2019 9:48 pm

Hi,

I'm having issues with the PyPortal that came with Adabox 011. The portal
starts but doesn't show a disk drive when connecting to the computer. I have
tried different cables and computers and no luck so far. I have other Circuit
Python devices and they show the disk drive when connecting to the computer.
I also double clicked the reset button and the neopixel in the back turns
red and no disk drive either. Also, there is not serial port detected. I
tried the arduino app, but with no serial port available, I cannot reprogram
the pyportal. All the solutions that I find in the forums assume that a disk drive
will show up in the computer. Again, I have tried different computers (two
macbook pro and a Windows 10 machine). Different cables that work (Disk
Drive shows up) when connecting a Circuit Playground Express device. What
else can I do?

Thanks
Cesar

paks
 
Posts: 7
Joined: Thu Oct 11, 2018 10:02 am

Re: PyPortal issue - no USB drive for circuit python or uf2

by adafruit_support_carter on Mon Apr 08, 2019 7:11 pm

Hey, sorry it's not working nicely. Can you clarify what you mean by "it starts". Does it show anything on the display when you power it up?

adafruit_support_carter
 
Posts: 11630
Joined: Tue Nov 29, 2016 2:45 pm

Re: PyPortal issue - no USB drive for circuit python or uf2

by paks on Thu Apr 11, 2019 4:44 pm

When the PyPortal starts, it shows the default app that came preinstalled.

paks
 
Posts: 7
Joined: Thu Oct 11, 2018 10:02 am

Re: PyPortal issue - no USB drive for circuit python or uf2

by adafruit_support_carter on Thu Apr 11, 2019 8:19 pm

OK, so it's not something fundamental like a bad power supply. And it's running what it came loaded with, so it's working to a point. It really seems like a USB cable issue, but you've tried several - including one(s) that are known to work with other boards.

See if any of the known issues here apply in your setup:
https://learn.adafruit.com/welcome-to-c ... n/overview

adafruit_support_carter
 
Posts: 11630
Joined: Tue Nov 29, 2016 2:45 pm

Re: PyPortal issue - no USB drive for circuit python or uf2

by paks on Sun Apr 14, 2019 10:54 pm

I read the troubleshooting section about issues with antiviruses and other programs. I used a Windows 10 machine with only malwarebytes. In that machine, I get the following error dialog when I connect the pyportal:
usb.png
usb.png (8.14 KiB) Viewed 371 times
.

paks
 
Posts: 7
Joined: Thu Oct 11, 2018 10:02 am

Re: PyPortal issue - no USB drive for circuit python or uf2

by paks on Mon Apr 22, 2019 9:51 pm

I decided to do a continuity test using the new DIY USB CABLE PARTS - STRAIGHT MICRO B PLUG. In the case of the PyPortal the pin marked in red in the picture doesn't connect with any pin in the PyPortal USB connector.
pyportal_usb.jpg
pyportal_usb.jpg (191.83 KiB) Viewed 334 times
I decided to do the same test in a Circuit Playground Express board and the same pin connects in the Circuit Playground Express with the pin marked in the picture.
playgroud_usb.jpg
playgroud_usb.jpg (203.54 KiB) Viewed 334 times
I don't have the schematics for either board. So, am I correct and the PyPortal should connect to the same pin as the Circuity Playground Express? Is so, then It looks like I have a hardware issue.

paks
 
Posts: 7
Joined: Thu Oct 11, 2018 10:02 am

Re: PyPortal issue - no USB drive for circuit python or uf2

by adafruit_support_carter on Tue Apr 23, 2019 12:31 pm

Interesting test. Yes, those should be connected. Just to be sure, you were doing a continuity test between these two points? Or, if not, what was the point on the PyPortal side that you were testing?
test_points.jpg
test_points.jpg (175.91 KiB) Viewed 316 times

adafruit_support_carter
 
Posts: 11630
Joined: Tue Nov 29, 2016 2:45 pm

Re: PyPortal issue - no USB drive for circuit python or uf2

by paks on Tue Apr 23, 2019 4:18 pm

I tested point A with all the points in PyPortal including point B. My tester did not beep with any of them.

paks
 
Posts: 7
Joined: Thu Oct 11, 2018 10:02 am

Re: PyPortal issue - no USB drive for circuit python or uf2

by adafruit_support_carter on Tue Apr 23, 2019 4:37 pm

That's one of the USB data pins, so would explain what we are seeing. Power is getting in, so the included program runs. But without data, there's no communication back and forth. Where I've circled is also where the USB pin goes from the connector to the PCB. Does it look like maybe the soldering there has an issue? And if so, is that something you think you could touch up soldering-wise?

adafruit_support_carter
 
Posts: 11630
Joined: Tue Nov 29, 2016 2:45 pm

Re: PyPortal issue - no USB drive for circuit python or uf2

by paks on Tue Apr 30, 2019 4:01 pm

I fixed the connection and the continuity has been restored. But, I'm still getting the same error I posted on Windows 10. Now, I'm out of ideas. What else can I do?

paks
 
Posts: 7
Joined: Thu Oct 11, 2018 10:02 am

Re: PyPortal issue - no USB drive for circuit python or uf2

by adafruit_support_carter on Tue Apr 30, 2019 10:18 pm

In your first post you mention trying other computers. Were they all Win 10 also? If not, what OS were they?

Also, do you get the same behavior if you try and put the board in bootloader mode:
https://learn.adafruit.com/adafruit-pyp ... hon#step-5
and see if you can get the PORTALBOOT folder to show up?

adafruit_support_carter
 
Posts: 11630
Joined: Tue Nov 29, 2016 2:45 pm

Re: PyPortal issue - no USB drive for circuit python or uf2

by paks on Fri May 03, 2019 6:03 pm

I tried, 2 Mac Powerbooks and 1 Windows 10 machine. They all show the same behavior. They all load the disk drive for a Circuit Playgroud Express board that I have. I tried also to put the board in bootloader mode and the same thing happens (no disk). When in that mode both leds in the back are red (the one next to the USB connector pulse red).

paks
 
Posts: 7
Joined: Thu Oct 11, 2018 10:02 am

Re: PyPortal issue - no USB drive for circuit python or uf2

by adafruit_support_carter on Mon May 06, 2019 2:24 pm

OK, really weird. Not sure what this is. Thanks for trying all this testing. We can try a replacement. Send an email to support@adafruit.com with a link to this thread and your order number and they can send you a replacement PyPortal.

adafruit_support_carter
 
Posts: 11630
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.