0

Hallowing Not Waking - PIR issue?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Hallowing Not Waking - PIR issue?

by swc on Fri Oct 12, 2018 11:57 pm

Can someone confirm the current version of the All Seeing Skull code works 'as is' with their Hallowing?

I downloaded the code and install it, but the eye only comes on for a couple seconds before going to a black screen. The screen is on, just black. If I restart the Hallowing, the same thing happens.

Downloading the Uncanny Eyes master code and installing it, it runs fine perpetually, but I wanted to have the motion sensing via the PIR.

I tried editing the code in Uncanny eyes, by adding a pinMode(A11, INPUT) in setup, and a digitalRead(A11) each loop and print the value to serial (with intent to modify the code further when it worked) only to find that my PIR never reads HIGH.

So now I think there is a problem with my PIR and/or the connectors from my box, and that is why the All Seeing Skull is going to sleep and blanking and why I'm never reading motion in the modified Uncanny Eyes.

Thoughts?

swc
 
Posts: 1
Joined: Mon Dec 06, 2010 11:08 am

Re: Hallowing Not Waking - PIR issue?

by orcrist on Sun Oct 14, 2018 6:34 pm

Interestingly, I have precisely the opposite problem.
The PIR is constantly triggered, even if I completely cover it up.

I added a Serial.println statement to check in this section:
Code: Select all | TOGGLE FULL SIZE
  //PIR detect
  if(digitalRead(MOTION_SENSOR_PIN)){  //PIR triggered
    Serial.println("PIR triggered");
    lastTriggerTime = millis();  //save last trigger time
  }

and the output streams "PIR triggered" nonstop.

orcrist
 
Posts: 11
Joined: Wed Jan 11, 2017 1:13 pm

Re: Hallowing Not Waking - PIR issue?

by orcrist on Sun Oct 14, 2018 6:43 pm

I tried unplugging and re-plugging the PIR sensor, and now I have the same symptom as the OP. No matter much motion I make, the PIR won't trigger any more.

EDIT: Correction. When I replugged, I had inadvertently plugged it into the "neopix" port. Now I'm back to constant triggering.

OP: Maybe you can check if you have it plugged into the right place.

This constant triggering reminds me of the behavior of the PIR I got from Adabox 003 when trying to use 3.3v (before I followed the hack to get around that).

orcrist
 
Posts: 11
Joined: Wed Jan 11, 2017 1:13 pm

Re: Hallowing Not Waking - PIR issue?

by jpiatt on Mon Oct 15, 2018 1:08 am

I'm having the same issue (Hallowing does not go to sleep) but I couldn't find the place in the uncannyEyes code were the PIR data pin is being tested. Am I missing something? (probably)

jpiatt
 
Posts: 2
Joined: Wed Apr 18, 2012 4:38 am

Re: Hallowing Not Waking - PIR issue?

by johnpark on Tue Oct 16, 2018 1:37 pm

If you haven't already, try adjusting the sensitivity and delay time trim pots, as well as checking the retrigger setting jumper as shown here: https://learn.adafruit.com/pir-passive-infrared-proximity-motion-sensor/

johnpark
 
Posts: 413
Joined: Wed Mar 25, 2009 2:15 pm

Re: Hallowing Not Waking - PIR issue?

by orcrist on Tue Oct 16, 2018 2:16 pm

johnpark wrote:If you haven't already, try adjusting the sensitivity and delay time trim pots, as well as checking the retrigger setting jumper as shown here: https://learn.adafruit.com/pir-passive-infrared-proximity-motion-sensor/

Those aren't on the Adabox009 version of the PIR. It's all embedded components:
Adabox009 PIR.png
Adabox009 PIR.png (601.92 KiB) Viewed 201 times


Compare to the PIR I got in Adabox003 which I had to solder the 3.3v wire to the jumper pin to avoid this constant trigger problem:
https://cdn.discordapp.com/attachments/ ... 182811.jpg
That was the workaround suggested in that discord thread from this article:
https://randomnerdtutorials.com/modifyi ... k-at-3-3v/

The problem here is that the layout of the components is different, and there are no convenient jumper pins to solder to.
I was wondering how that would be worked around for the Hallowing, and it appears it wasn't. In fact, even with usb power, the positive pin for the sensor shows only about 3.8 volts.

I really don't see how this PIR *can* work with the hallowing.

orcrist
 
Posts: 11
Joined: Wed Jan 11, 2017 1:13 pm

Re: Hallowing Not Waking - PIR issue?

by johnpark on Tue Oct 16, 2018 2:24 pm

EDIT: I expanded your picture and now see the sensor, sorry! Looking into this now.

Could you please post a picture of the PIR sensor you got? The ones in my AdaBox have the two trim pots and jumper.

johnpark
 
Posts: 413
Joined: Wed Mar 25, 2009 2:15 pm

Re: Hallowing Not Waking - PIR issue?

by orcrist on Tue Oct 16, 2018 2:28 pm

Just to be clear though. I am convinced this is the 3v problem. I never got the other PIR (in the discord link) to work at anything under 5v until I did that solder hack. Otherwise it also triggered constantly.

Edit: i.e. under 5v the potentiometers had no discernible effect.

orcrist
 
Posts: 11
Joined: Wed Jan 11, 2017 1:13 pm

Re: Hallowing Not Waking - PIR issue?

by johnpark on Tue Oct 16, 2018 2:32 pm

@jpaitt it is in the All_Seeing_Skull.ino file that the PIR code is used: https://github.com/adafruit/Adafruit_Le ... _Skull.ino

johnpark
 
Posts: 413
Joined: Wed Mar 25, 2009 2:15 pm

Re: Hallowing Not Waking - PIR issue?

by johnpark on Tue Oct 16, 2018 2:44 pm

@Orcrist interesting -- I didn't have any trouble with the tune-able PIR sensors working on HalloWings, and I tried a couple different ones. Let me see if we can find any alternate methods, possibly using the NeoPix port which supplies 5V.

johnpark
 
Posts: 413
Joined: Wed Mar 25, 2009 2:15 pm

Re: Hallowing Not Waking - PIR issue?

by adafruit2 on Tue Oct 16, 2018 6:15 pm

orcrist, can you take a photo of the other side of the PIR? that is odd that it looks different!

adafruit2
Site Admin
 
Posts: 18316
Joined: Fri Mar 11, 2005 7:36 pm

Re: Hallowing Not Waking - PIR issue?

by jpiatt on Tue Oct 16, 2018 7:00 pm

@johnpark Thanks! I don't know how I managed to grab the wrong sketch but now that I'm using the right one, it works great!!

jpiatt
 
Posts: 2
Joined: Wed Apr 18, 2012 4:38 am

Re: Hallowing Not Waking - PIR issue?

by orcrist on Tue Oct 16, 2018 7:03 pm

I have to apologize.
I had had a 3rd PIR from another source lying around which had the jst connector and I somehow mixed that up with the one that came in the adabox009.

I have attached the right one, and now it behaves like the Adabox003 one did:
If the USB is connected it triggers correctly. If I'm on the lipo it triggers constantly. So this is an improvement in that I can connect the supply voltage to that jumper pin to do the hack from https://randomnerdtutorials.com/modifyi ... k-at-3-3v/
I think I can work with that.

orcrist
 
Posts: 11
Joined: Wed Jan 11, 2017 1:13 pm

Re: Hallowing Not Waking - PIR issue?

by johnpark on Tue Oct 16, 2018 8:13 pm

@jpaitt, great!

johnpark
 
Posts: 413
Joined: Wed Mar 25, 2009 2:15 pm

Re: Hallowing Not Waking - PIR issue?

by johnpark on Tue Oct 16, 2018 8:16 pm

@ochrist, ah, yes, makes sense -- that project is plugged in over USB since it is to remain active for many hours at a time, so the PIR sensor doesn't have any trouble w voltage.

johnpark
 
Posts: 413
Joined: Wed Mar 25, 2009 2:15 pm

Please be positive and constructive with your questions and comments.