0

PYGAMER display from ADABox012 not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

PYGAMER display from ADABox012 not working

by rlrobertson8291 on Tue Jun 25, 2019 11:19 pm

Just received my ADABox012 and assembled the PYGAMER. Powered up the device and received a display for the order fill game then the display went white. No matter what I try, I get a white display like it is just the backlight. Tried with just USB powered and battery both, sam thing. Any suggestions on what to try?

rlrobertson8291
 
Posts: 7
Joined: Wed Oct 28, 2015 9:17 am

Re: PYGAMER display from ADABox012 not working

by adafruit_support_carter on Wed Jun 26, 2019 7:47 pm

Weird. So it worked for a little bit and then stopped working. About how long was the display operational for? Can you correlate the white scree to anything?

Go ahead and remove the PyGamer from the case for the sake of troubleshooting. If you can, please post a photo of the screen side of the board so we can look for anything obvious wrong with the hardware.

adafruit_support_carter
 
Posts: 12976
Joined: Tue Nov 29, 2016 2:45 pm

Re: PYGAMER display from ADABox012 not working

by rlrobertson8291 on Thu Jun 27, 2019 12:33 pm

The screen was good for about a minute or two. I was able to get the little game up and it went white while playing with the game. I've attached a couple photos as requested.
20190627_095547.jpg
Front View
20190627_095547.jpg (393.21 KiB) Viewed 238 times

20190627_095624.jpg
White Screen
20190627_095624.jpg (350.3 KiB) Viewed 238 times

rlrobertson8291
 
Posts: 7
Joined: Wed Oct 28, 2015 9:17 am

Re: PYGAMER display from ADABox012 not working

by adafruit_support_carter on Thu Jun 27, 2019 12:44 pm

Thanks. That all looks generally OK. Let's see if we can get the board to go into bootloader mode. Remove the battery for now so we can just focus on powering via USB. Then plug it in with a USB cable, turn the power switch ON, and the double press the RESET button. Also try a single press of RESET, since the button presses can vary depending on the previous software loaded.

More info on getting into bootloader mode:
https://learn.adafruit.com/adafruit-pyg ... loader-3-2

If it doesn't seem to work as shown on that link, describe what does happen. What does the screen do? What do the row on NeoPixel below the screen do? And does anything happen on the computer the PyGamer is attached to?

adafruit_support_carter
 
Posts: 12976
Joined: Tue Nov 29, 2016 2:45 pm

Re: PYGAMER display from ADABox012 not working

by rlrobertson8291 on Thu Jun 27, 2019 1:47 pm

Did as suggested and the following happened:

Double pressed the reset button and the display flashed off and back to white.
The neopixels at the bottom flashed red and then wen to a solid green.
The display stayed white.

Single pressed the reset button and the display flashed off and back to white.
The neopixels at the bottom stayed a solid green.

Each reset I get a "Disk Not Ejected Properly" notification on the computer (Mac).

20190627_123247.jpg
Reset results
20190627_123247.jpg (473.36 KiB) Viewed 227 times

rlrobertson8291
 
Posts: 7
Joined: Wed Oct 28, 2015 9:17 am

Re: PYGAMER display from ADABox012 not working

by rlrobertson8291 on Thu Jun 27, 2019 1:50 pm

If you look at the last picture, you will see that there appears to be a coating or whatever (black) to the right of the display that appears to be missing. Is this okay?

rlrobertson8291
 
Posts: 7
Joined: Wed Oct 28, 2015 9:17 am

Re: PYGAMER display from ADABox012 not working

by adafruit_support_carter on Thu Jun 27, 2019 2:02 pm

OK, that's promising. I think you're getting into bootloader mode with either single or double press of reset. And the green NeoPixels indicate it's OK. Are you seeing a PYGAMERBOOT folder show up and the "Disk Not Ejected Properly" message is about that?

Is this the area where you think something is missing?
display.jpg
display.jpg (43.69 KiB) Viewed 225 times

adafruit_support_carter
 
Posts: 12976
Joined: Tue Nov 29, 2016 2:45 pm

Re: PYGAMER display from ADABox012 not working

by rlrobertson8291 on Thu Jun 27, 2019 2:33 pm

Yes the PYGAMERBOOT is showing up in Finder and the "Disk Not Ejected Properly" message shows when I do the reset.
The area you have circled is the area I was concerned about. It looks like some of the coating is missing. I attached a closer view.

20190627_132604.jpg
20190627_132604.jpg (544.91 KiB) Viewed 215 times

rlrobertson8291
 
Posts: 7
Joined: Wed Oct 28, 2015 9:17 am

Re: PYGAMER display from ADABox012 not working

by adafruit_support_carter on Thu Jun 27, 2019 4:08 pm

That does look odd. Did it arrive like that or did you find any of what might have been there in the shipping packaging? We can probably just replace that, but curious if it's known how that happened at all?

adafruit_support_carter
 
Posts: 12976
Joined: Tue Nov 29, 2016 2:45 pm

Re: PYGAMER display from ADABox012 not working

by rlrobertson8291 on Thu Jun 27, 2019 8:16 pm

That is the way it came. It was partially hidden by the protective film. When I removed the film, that when i noticed it.

rlrobertson8291
 
Posts: 7
Joined: Wed Oct 28, 2015 9:17 am

Re: PYGAMER display from ADABox012 not working

by adafruit_support_carter on Thu Jun 27, 2019 9:16 pm

That's an odd one. Not sure why it's like that. Let's just replace it.

Send an email to support@adafruit.com with a link to this thread and your order number and they can send you a replacement PID 4242.

adafruit_support_carter
 
Posts: 12976
Joined: Tue Nov 29, 2016 2:45 pm

Re: PYGAMER display from ADABox012 not working

by rlrobertson8291 on Thu Jun 27, 2019 10:32 pm

You want this one back when I receive the replacement?

rlrobertson8291
 
Posts: 7
Joined: Wed Oct 28, 2015 9:17 am

Re: PYGAMER display from ADABox012 not working

by adafruit_support_carter on Fri Jun 28, 2019 12:26 pm

Thanks, but we do not need the other one back.

adafruit_support_carter
 
Posts: 12976
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.