0

Incorrect I2C pull-up detection on QT Py RP2040
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Incorrect I2C pull-up detection on QT Py RP2040

by joeblubaugh on Thu Jul 29, 2021 3:12 am

Twice in the last two days I've been using my QT Py RP2040 with the Stemma QT connector to talk to two devices. I'm initializing the i2c bus using the correct pins, but I get this strange error:
Code: Select all | TOGGLE FULL SIZE
>>> import board
>>> import busio
>>> i2c = busio.I2C(board.SCL1, board.SDA1)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
RuntimeError: No pull up found on SDA or SCL; check your wiring
>>>


I've tried using the flash_nuke.uf2, reinstalling CircuitPython after nuking, rebooting the board, Safely ejecting the board, removing power, and then rebooting the board ...

joeblubaugh
 
Posts: 2
Joined: Thu Jul 29, 2021 3:09 am

Re: Incorrect I2C pull-up detection on QT Py RP2040

by dastels on Thu Jul 29, 2021 12:05 pm

What I2C devices do you have connected to the STEMMA-QT connector?

Dave

dastels
 
Posts: 7312
Joined: Tue Oct 20, 2015 3:22 pm

Re: Incorrect I2C pull-up detection on QT Py RP2040

by joeblubaugh on Fri Jul 30, 2021 12:45 am

I have an APDS-9960, changed to a 0.91" OLED display.

I realized something today - if I plug this into a power adapter and not my MacBook, I don't encounter this issue. The uc starts up quickly and the application seems to work every time.

joeblubaugh
 
Posts: 2
Joined: Thu Jul 29, 2021 3:09 am

Please be positive and constructive with your questions and comments.