Due to high demand and inclement weather, expect some shipping delays at this time, orders may not ship for 4-5 business days.
0

Seeing unreliable I2C with PyPortal Titano
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Seeing unreliable I2C with PyPortal Titano

by gammaburst on Sun Nov 28, 2021 12:29 am

Myself and another forum member are seeing unreliable I2C with PyPortal Titano + CircuitPython. I tried busio and bitbangio libraries, but both misbehave in different ways. Using an oscilloscope I see obvious bus malfunctions. Are we doing something wrong? Please see this discussion:
viewtopic.php?f=19&t=185204&p=898183#p899055

gammaburst
 
Posts: 653
Joined: Thu Dec 31, 2015 12:06 pm

Re: Seeing unreliable I2C with PyPortal Titano

by danhalbert on Sun Nov 28, 2021 10:16 am

Answered in that thread.

danhalbert
 
Posts: 2985
Joined: Tue Aug 08, 2017 12:37 pm

Re: Seeing unreliable I2C with PyPortal Titano

by gammaburst on Tue Nov 30, 2021 10:40 am

Did you notice my response on Page 2?
Adafruit forums need a big obvious button at the bottom: Discussion continues on Page 2.

gammaburst
 
Posts: 653
Joined: Thu Dec 31, 2015 12:06 pm

Re: Seeing unreliable I2C with PyPortal Titano

by danhalbert on Tue Nov 30, 2021 10:50 am

I did notice your response, and didn't have a chance to respond yet. Let's not continue the discussion in two threads.

danhalbert
 
Posts: 2985
Joined: Tue Aug 08, 2017 12:37 pm

Please be positive and constructive with your questions and comments.