Black Lives Matter - Action and Equality. ... Adafruit joins the Stop Hate for Profit campaign.
0

Adafruit-blinka install on macOS Catalina failing
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Adafruit-blinka install on macOS Catalina failing

by ryinsf on Sat Mar 28, 2020 12:37 am

I just bought a Adafruit FT232H and encountered the following error while running through the CircuitPython libraries installation instructions. Any help you can give to get me moving forward would be very much appreciated.

Rob-MBP-16:~ ryoung$ pip3 install adafruit-blinka
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
Collecting adafruit-blinka
Using cached Adafruit-Blinka-4.2.0.tar.gz (81 kB)
Requirement already satisfied: Adafruit-PlatformDetect in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from adafruit-blinka) (2.5.0)
Requirement already satisfied: Adafruit-PureIO in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from adafruit-blinka) (1.0.4)
Requirement already satisfied: pyftdi>=0.40.0 in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from adafruit-blinka) (0.48.3)
Collecting sysv_ipc
Using cached sysv_ipc-1.0.1.tar.gz (102 kB)
Requirement already satisfied: pyserial>=3.0 in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from pyftdi>=0.40.0->adafruit-blinka) (3.4)
Requirement already satisfied: pyusb>=1.0.0 in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from pyftdi>=0.40.0->adafruit-blinka) (1.0.2)
Installing collected packages: sysv-ipc, adafruit-blinka
Running setup.py install for sysv-ipc ... error
ERROR: Command errored out with exit status 1:
command: /Library/Frameworks/Python.framework/Versions/3.8/bin/python3.8 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/dr/rc8jt85j4_vf0n8x477fp6bm0000gn/T/pip-install-sqigxmf4/sysv-ipc/setup.py'"'"'; __file__='"'"'/private/var/folders/dr/rc8jt85j4_vf0n8x477fp6bm0000gn/T/pip-install-sqigxmf4/sysv-ipc/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /private/var/folders/dr/rc8jt85j4_vf0n8x477fp6bm0000gn/T/pip-record-4fwce7f7/install-record.txt --single-version-externally-managed --compile --install-headers /Library/Frameworks/Python.framework/Versions/3.8/include/python3.8/sysv-ipc
cwd: /private/var/folders/dr/rc8jt85j4_vf0n8x477fp6bm0000gn/T/pip-install-sqigxmf4/sysv-ipc/
Complete output (16 lines):
******************************************************************************
* Setup can't determine the value of PAGE_SIZE on your system, so it will
* default to 4096 which may not be correct.
*
* Please report this message and your operating system info to the package
* maintainer listed in the README file.
******************************************************************************
running install
running build
running build_ext
building 'sysv_ipc' extension
creating build
creating build/temp.macosx-10.9-x86_64-3.8
gcc -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -arch x86_64 -g -I/Library/Frameworks/Python.framework/Versions/3.8/include/python3.8 -c sysv_ipc_module.c -o build/temp.macosx-10.9-x86_64-3.8/sysv_ipc_module.o
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
error: command 'gcc' failed with exit status 1
----------------------------------------
ERROR: Command errored out with exit status 1: /Library/Frameworks/Python.framework/Versions/3.8/bin/python3.8 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/dr/rc8jt85j4_vf0n8x477fp6bm0000gn/T/pip-install-sqigxmf4/sysv-ipc/setup.py'"'"'; __file__='"'"'/private/var/folders/dr/rc8jt85j4_vf0n8x477fp6bm0000gn/T/pip-install-sqigxmf4/sysv-ipc/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /private/var/folders/dr/rc8jt85j4_vf0n8x477fp6bm0000gn/T/pip-record-4fwce7f7/install-record.txt --single-version-externally-managed --compile --install-headers /Library/Frameworks/Python.framework/Versions/3.8/include/python3.8/sysv-ipc Check the logs for full command output.

ryinsf
 
Posts: 8
Joined: Wed Feb 10, 2016 1:50 am

Please be positive and constructive with your questions and comments.