Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

Pyportal No Longer Connects
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Pyportal No Longer Connects

by Zwilrich on Mon Jun 22, 2020 4:46 pm

I have a PyPortal that collects temperature and humidity data. It shows the data on the screen, transmits it via MQTT, and also outputs it via the serial port. I disconnected it from its power supply and connected it to a computer to update my program. It does not connect to the computer: no USB enumeration, no serial port, and no disk drive.

Things I've tried to get it to work:
  • Different USB cables
  • Different USB ports
  • Different computers
Other diagnostic information:
  • My program still runs.
  • If I double-click the reset button, the NeoPixel turns red but there is still no connection.
  • A magnified examination of the traces from the USB connector to the processor show no damage and no bad solder joints.
  • Firmware is either 4.0.2 or 4.1.0 (I can't connect to check).
I purchased this PyPortal from Adafruit although I'm not sure when I purchased this particular one.

Any suggestions on what to do next?

Zwilrich
 
Posts: 15
Joined: Sun Dec 11, 2016 6:52 pm

Re: Pyportal No Longer Connects

by siddacious on Thu Jun 25, 2020 1:25 pm

When in bootloader mode from double-tapping the reset button, does the red SMD LED near the USB socket blink or pulse? If so, slow or fast?

siddacious
 
Posts: 271
Joined: Fri Apr 21, 2017 3:09 pm

Re: Pyportal No Longer Connects

by Zwilrich on Thu Jun 25, 2020 2:05 pm

Going by memory, it pulses at a slow rate.

Zwilrich
 
Posts: 15
Joined: Sun Dec 11, 2016 6:52 pm

Re: Pyportal No Longer Connects

by danhalbert on Thu Jun 25, 2020 7:19 pm

If you have tried different computers, were they all Windows, or did you try a Mac or Linux also? If you have a Raspberry Pi, that would be an easy Linux test. Double-clicking and seeing whether you see the PORTALBOOT drive is the test.

If the LED is pulsing slowly, then the bootloader is intact. There is an issue with unprotected bootloaders overwriting themselves with zeros. We have also seen a few PyPortals just have USB failures of some kind.

danhalbert
 
Posts: 2053
Joined: Tue Aug 08, 2017 12:37 pm

Re: Pyportal No Longer Connects

by Zwilrich on Thu Jun 25, 2020 8:40 pm

I remembered incorrectly; it is a fast pulse, not a slow pulse.

No response when connecting to my Raspberry Pi, with or without the double-tap. dmesg does not show anything after connecting, not after the double-tap.

Zwilrich
 
Posts: 15
Joined: Sun Dec 11, 2016 6:52 pm

Re: Pyportal No Longer Connects

by danhalbert on Thu Jun 25, 2020 8:54 pm

The fast pulse means that the bootloader thinks it is not connected to USB. I would just suggest that you make sure that one of the cables you try does work properly with another board or some other data-passing device. We recently had one person try multiple cables, but it turned out they were -all- power-only.

Otherwise it does sound as if the USB circuitry or mechanical aspects have failed somewhere, unfortunately.

danhalbert
 
Posts: 2053
Joined: Tue Aug 08, 2017 12:37 pm

Re: Pyportal No Longer Connects

by Zwilrich on Thu Jun 25, 2020 9:31 pm

I pulled a cable out of the pile and connected to my phone--it enumerated. Tried the same cable on the PyPortal--no result on both my Win 10 computer and my Pi.

Zwilrich
 
Posts: 15
Joined: Sun Dec 11, 2016 6:52 pm

Re: Pyportal No Longer Connects

by adafruit2 on Sun Jun 28, 2020 7:17 pm

on the win 10 - just to be sure, please try another USB cable and connect directly to a port on the motherboard (not thru a hub) and also try going thru a hub. its worth a shot!

adafruit2
Site Admin
 
Posts: 19225
Joined: Fri Mar 11, 2005 7:36 pm

Re: Pyportal No Longer Connects

by Zwilrich on Wed Jul 08, 2020 11:06 pm

I finally got a chance to get back to this.
The connections have always been direct; not through a hub.
With a powered USB hub and tested good cables:
Win10: No response in Device Manager when connecting the Pyportal or when switching it to load firmware mode.
Pi 3: No response in dmesg or lsusb after connecting the Pyportal or after switching it to load firmware mode.

Zwilrich
 
Posts: 15
Joined: Sun Dec 11, 2016 6:52 pm

Re: Pyportal No Longer Connects

by adafruit2 on Wed Jul 08, 2020 11:28 pm

tragic, email support@adafruit for a new pyportal

adafruit2
Site Admin
 
Posts: 19225
Joined: Fri Mar 11, 2005 7:36 pm

Re: Pyportal No Longer Connects

by Zwilrich on Wed Jul 08, 2020 11:46 pm

Thank you for the quick response.

Zwilrich
 
Posts: 15
Joined: Sun Dec 11, 2016 6:52 pm

Please be positive and constructive with your questions and comments.