Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Feather M0X: No FEATHERBOOT
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Feather M0X: No FEATHERBOOT

by flounder on Wed Aug 19, 2020 10:19 pm

If I double-click reset, my brand-new-out-of-the-bag-arrived-from-DigiKey-two-days-ago Feather M0 Express disappears from the directory listing. No FEATHERBOOT appears. Since I saw that I was running CircuitPython 2.2.4, I thought I should update to 5.3.1. So, following the instructions, I got the CP 5.3.1 UF2 image downloaded, double-clicked, and no joy. Tried all kinds of rhythms. No joy. Search the forum, found the suggestion:
Code: Select all | TOGGLE FULL SIZE
import microcontroller
microcontroller.on_next_reset(microcontroller.RunMode.BOOTLOADER)
microcontroller.reset()

and, as has already been described in another thread, this made no difference. Unfortunately, that thread ended and I have seen no way to get to FEATHERBOOT.

So what should I try next? Had a really cool project I was going to work on tonight. Sigh.

flounder
 
Posts: 416
Joined: Wed Sep 18, 2013 9:10 pm
Location: Pittsburgh PA

Re: Feather M0X: No FEATHERBOOT

by tannewt on Thu Aug 20, 2020 1:59 pm

What do the LEDs do? What OS are you on?

The Discord: https://adafru.it/discord can be a quicker way to get help too. The forum is better for long term debugging though.

tannewt
 
Posts: 1837
Joined: Thu Oct 06, 2016 8:48 pm

Re: Feather M0X: No FEATHERBOOT

by flounder on Mon Sep 07, 2020 1:30 pm

I am using Windows 10 Pro. See attached screenshot. When I doubleclick, I get the LED showing green, and the power LED slowly fading on and off. But this is not what I was supposed to see.

Sorry for the delay in response. This is the first chance I've had to work on this since I posted the question. Retirement gives me so much to do!
Attachments
2020-09-07 13.10.54.jpg
2020-09-07 13.10.54.jpg (363.74 KiB) Viewed 58 times
win10.PNG
win10.PNG (67 KiB) Viewed 58 times

flounder
 
Posts: 416
Joined: Wed Sep 18, 2013 9:10 pm
Location: Pittsburgh PA

Re: Feather M0X: No FEATHERBOOT

by danhalbert on Mon Sep 07, 2020 2:07 pm

flounder wrote:I am using Windows 10 Pro. See attached screenshot. When I doubleclick, I get the LED showing green, and the power LED slowly fading on and off. But this is not what I was supposed to see.


That is what you should see after double-clicking. The "pulsing" LED shows that the bootloader is listening.

1. Since you don't see FEATHERBOOT after double-clicking, do you see the CIRCUITPY drive when you single click?
2. Do you have any third-party antivirus installed, such as Kaspersky or ESET?
3. Do you have any disk-checking programs installed, such as Hard Disk Sentinel or AIDA64 installed?
4. Do you have any other utility programs installed, such as Acronis Backup, or a WD driver for an external USB drive?

See https://learn.adafruit.com/welcome-to-c ... -2978448-5 for some ideas. Usually these problems are due to some third-party software, and you might have yet another piece of software that's interfering.

If you have another computer to try, even a Raspberry Pi, it should should FEATHERBOOT when you double-click.

danhalbert
 
Posts: 2134
Joined: Tue Aug 08, 2017 12:37 pm

Re: Feather M0X: No FEATHERBOOT

by flounder on Thu Oct 15, 2020 1:40 am

This is my fourth attempt to post a reply. It keeps getting stuck as I am trying to add photos, telling me that the photo (a 57K JPEG) is > 1 MB. Huh? Once more.

This time, I was having the same problem with CPX. I plugged it in:
2020-10-15 00.14.34.jpg
2020-10-15 00.14.34.jpg (681.26 KiB) Viewed 33 times


I could see CIRCUITPY:
2020-10-15 00.38.44.jpg
2020-10-15 00.38.44.jpg (34.15 KiB) Viewed 33 times


I followed up. Indeed, I had Acronis installed. I don't know why. I deleted it and rebooted. Nothing changed. I read further, and saw that I might have had the wrong driver installed in Windows 10. So I removed it:
nocpx.jpg
nocpx.jpg (85.25 KiB) Viewed 33 times

And rebooted. But nothing changed. When I hit reset, once, I got the green lights, but no CPLAYBOOT:
Note that I cannot attach the picture. I have no idea why. I keep saying "Add the File," but nothing happens, so I wonder if there is an undocumented limit of three pictures. If so, failing to state this limit explicitly is an error. So I will post this much, and start another post.

flounder
 
Posts: 416
Joined: Wed Sep 18, 2013 9:10 pm
Location: Pittsburgh PA

Re: Feather M0X: No FEATHERBOOT

by flounder on Thu Oct 15, 2020 1:43 am

So here's my attempt to get a fourth image posted, ideally circumventing the undocumented limitation:
2020-10-15 01.01.10.jpg
2020-10-15 01.01.10.jpg (56.77 KiB) Viewed 33 times

So now I cannot use either CircuitPython (latest version) or MakeCode. I have no other antivirus software installed, other than Windows Defender.

What is going on here?

flounder
 
Posts: 416
Joined: Wed Sep 18, 2013 9:10 pm
Location: Pittsburgh PA

Re: Feather M0X: No FEATHERBOOT

by danhalbert on Thu Oct 15, 2020 10:00 am

Indeed, I had Acronis installed. I don't know why. I deleted it and rebooted. Nothing changed.

Acronis can be a big nuisance. It can leave drivers behind, even after being uninstalled. There are cleanup utilities, though I'm not sure if they solve the problem. Try the appropriate cleanup program from here:
https://kb.acronis.com/content/40366

See also this thread for some debugging we did with another use to remove another driver (not Acronis) that was interfering with a BOOT drive.

I would also like to see the list of drivers associated with a particular drive. Get CIRCUITPY to show up. Open Device Manager (right-click on Start Menu), then right click on the CIRCUITPY drive, and choose Properties. Choose the Drivers tab, then click "Driver Details". Take a screen shot of everything. Here's an example (but not using CIRCUITPY). Try this before and after the Acronis cleanup program.

drivers.png
drivers.png (63.45 KiB) Viewed 23 times


(btw, I believe you are right that there's a limit of three attachments, and that could be better documented)

danhalbert
 
Posts: 2134
Joined: Tue Aug 08, 2017 12:37 pm

Re: Feather M0X: No FEATHERBOOT

by flounder on Tue Oct 20, 2020 12:26 am

Sorry for the delay. Life is what happens when you are making other plans. Major number of minor crises in the last week. So here's the screen snapshot:
m4.PNG
m4.PNG (414.2 KiB) Viewed 10 times

By this time, I am back to where I started, using an M4 Express, running NeoPixels under CircuitPython. Unsuccessfully, I might add, but that's part of a different set of problems that I have reported under "Glowy things".

This is after I ran the Acronis cleanup.

flounder
 
Posts: 416
Joined: Wed Sep 18, 2013 9:10 pm
Location: Pittsburgh PA

Please be positive and constructive with your questions and comments.