Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

mpy-cross for CircuitPython 5.X
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

mpy-cross for CircuitPython 5.X

by elin05 on Sat Sep 19, 2020 11:40 am

I cannot find a binary for mpy-cross for CircuitPython 5.x anywhere. Amazon S3 (https://adafruit-circuit-python.s3.amaz ... mpy-cross/) only has 6.0.0-alpha.3 binaries. Where can I find a 5.x mpy-cross binary (for macOS Mojave)?

Alternatively, I've been trying to build the tool using the instructions on https://learn.adafruit.com/welcome-to-c ... -questions. However, I get the following error:

Code: Select all | TOGGLE FULL SIZE
ERICs-MBP:mpy-cross eric$ make V=2
Use make V=1, make V=2 or set BUILD_VERBOSE similarly in your environment to increase build verbosity.
msgfmt -o build/genhdr/en_US.mo ../locale/en_US.po
make: msgfmt: No such file or directory
make: *** [build/genhdr/en_US.mo] Error 1
ERICs-MBP:mpy-cross eric$


How do I resolve this issue?

elin05
 
Posts: 60
Joined: Tue Jun 11, 2013 4:27 pm

Re: mpy-cross for CircuitPython 5.X

by kevinjwalters on Mon Sep 21, 2020 8:50 am

To add some info to the precompiled part of your question, @dhalbert mentioned at the end of Precompiled versions of mpy-cross for CP 4, 5, 6:

You can use these 6.0.0 executables for 4.x, 5.x, and 6.x.

kevinjwalters
 
Posts: 764
Joined: Sun Oct 01, 2017 3:15 pm

Re: mpy-cross for CircuitPython 5.X

by danhalbert on Mon Sep 21, 2020 10:01 am

As kevinjwalters mentions (thanks!), the 6.x binaries are fine.

The missing file you are seeing during the build is due to the `gettext` package not being installed. See the setup instructions here:
https://learn.adafruit.com/building-circuitpython/macos
(I"m assuming "MBP" is Macbook Pro")

danhalbert
 
Posts: 2134
Joined: Tue Aug 08, 2017 12:37 pm

Please be positive and constructive with your questions and comments.