Due to high demand, expect some shipping delays at this time - orders may not ship for up to 2-3 business days.
0

Titano graphics problems
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Titano graphics problems

by mrbluegrass on Wed Dec 23, 2020 6:44 pm

noise.jpg
what it looked like when i first plugged it in and what it does most of the time after power cycling
noise.jpg (179.66 KiB) Viewed 108 times
upsideDownBackwards.jpg
after another power cycle it typically looks like this
upsideDownBackwards.jpg (163.57 KiB) Viewed 108 times
CorrectImage.jpg
this is what it should look like after many power cycles
CorrectImage.jpg (138.9 KiB) Viewed 108 times
Purchased a new Titano on Nov 20 (#2412408-7591604208), plugged it in and the display was all colored noise, not what was expected. I have tried doing a few other things and the graphics controller seems to be hosed. Sometimes a simple .bmp image is 3/4 screen and up-side down/backwards, sometimes i get colored noise, sometimes i get an image that is 3/4 size right-side up, and once in a while i get the whole image correctly. I have to keep power cycling by unplugging/ plugging back in until i get what should be there.
Using: Adafruit CircuitPython 6.0.0 on 2020-11-16; Adafruit PyPortal Titano with samd51j20
see attached code and images.
i would like a refund OR replacement.
thanks

-------------code-------------
Code: Select all | TOGGLE FULL SIZE
import time
import board
from adafruit_pyportal import PyPortal

# Set up where we'll be fetching data from
DATA_SOURCE = "https://www.adafruit.com/api/quotes.php"
QUOTE_LOCATION = [0, 'text']
AUTHOR_LOCATION = [0, 'author']

# the current working directory (where this file is)
cwd = ("/"+__file__).rsplit('/', 1)[0]

"""
pyportal = PyPortal(url=DATA_SOURCE,
                    json_path=(QUOTE_LOCATION, AUTHOR_LOCATION),
                    status_neopixel=board.NEOPIXEL,
                    default_bg=cwd+"/TwiggyHomeBig.bmp",
                    text_font=cwd+"/fonts/Arial-ItalicMT-17.bdf",
                    text_position=((20, 120),  # quote location
                                   (5, 210)), # author location
                    text_color=(0xFFFFFF,  # quote text color
                                0x8080FF), # author text color
                    text_wrap=(35, # characters to wrap for quote
                               0), # no wrap for author
                    text_maxlen=(180, 30), # max text size for quote & author
                   )
"""

# speed up projects with lots of text by preloading the font!
pyportal = PyPortal(default_bg=cwd+"/TwiggyHomeBig.bmp")
pyportal.preload_font()

"""
while True:
    try:
        value = pyportal.fetch()
        print("Response is", value)
    except (ValueError, RuntimeError) as e:
        print("Some error occured, retrying! -", e)
    time.sleep(60)
"""
while True:
    pass

mrbluegrass
 
Posts: 12
Joined: Mon Apr 09, 2018 9:12 am

Re: Titano graphics problems

by dastels on Wed Dec 23, 2020 8:03 pm

This is odd behavior. First get CircuitPython and libraries up to date.

Dave

dastels
 
Posts: 9704
Joined: Tue Oct 20, 2015 3:22 pm

Re: Titano graphics problems

by mrbluegrass on Sat Jan 02, 2021 5:50 pm

PXL_20210102_212626525.jpg
image after updating all libraries and CP UF2
PXL_20210102_212626525.jpg (187.29 KiB) Viewed 72 times
PXL_20210102_212626525.jpg
image after updating all libraries and CP UF2
PXL_20210102_212626525.jpg (187.29 KiB) Viewed 72 times
Same thing happening:
downloaded the absolute latest libraries and UF2
adafruit-circuitpython-bundle-6.x-mpy-20210101
Adafruit CircuitPython 6.0.1 on 2020-12-28; Adafruit PyPortal Titano with samd51j20

and i get colored noise and backwards images.

Being a retired embedded hw/firmware guy ... my bet is some graphics clocking problem with power up (PLL's notoriously) that screws up the synchronization/timing and it never recovers until you power cycle it enough times.

mrbluegrass
 
Posts: 12
Joined: Mon Apr 09, 2018 9:12 am

Re: Titano graphics problems

by dastels on Sat Jan 02, 2021 8:29 pm

The colored snow makes me think "reset issue". You are getting an image though. I haven't seen a backwards image yet, though.

Dave

dastels
 
Posts: 9704
Joined: Tue Oct 20, 2015 3:22 pm

Re: Titano graphics problems

by mrbluegrass on Mon Jan 04, 2021 10:26 am

Hi Dave,
ok agree with colored snow maybe a reset issue.. I want a refund or store credit or new one please.. this is *not* usable.
what else do i have to do ???

thanks
Mark

mrbluegrass
 
Posts: 12
Joined: Mon Apr 09, 2018 9:12 am

Re: Titano graphics problems

by dastels on Mon Jan 04, 2021 11:29 am

I agree. This is not something that should ever happen.

Please email support@adafruit.com with a link to this thread, your order number, and request the replacement of one PyPortal Titano.

Dave

dastels
 
Posts: 9704
Joined: Tue Oct 20, 2015 3:22 pm

Re: Titano graphics problems

by mrbluegrass on Mon Jan 04, 2021 6:54 pm

Thank you sir!

mrbluegrass
 
Posts: 12
Joined: Mon Apr 09, 2018 9:12 am

Please be positive and constructive with your questions and comments.