0

Servo moves "randomly" on initialization of script?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: Servo moves "randomly" on initialization of script?

by adafruit_support_bill on Tue Apr 06, 2021 11:50 am

The Power pins are not controlled by the PCA9685. The OE pin controls only the signal output.

adafruit_support_bill
 
Posts: 81604
Joined: Sat Feb 07, 2009 10:11 am

Re: Servo moves "randomly" on initialization of script?

by adafruit_support_carter on Tue Apr 06, 2021 12:05 pm

Yep. Sorry for the confusion. The fab print may illustrate it even better:
https://learn.adafruit.com/assets/36270
As you can see, the 5V power rail is a simple trace which runs the whole length of the pins and is always connected.

adafruit_support_carter
 
Posts: 20679
Joined: Tue Nov 29, 2016 2:45 pm

Re: Servo moves "randomly" on initialization of script?

by nickstiv on Tue Apr 06, 2021 12:45 pm

adafruit_support_bill wrote:The Power pins are not controlled by the PCA9685. The OE pin controls only the signal output.



So in that case it seems unlikely that the OE pin would solve the issue I'm having? Any ideas? Or is this just a thing that happens on initialization that nothing can be done about?

nickstiv
 
Posts: 9
Joined: Tue Mar 30, 2021 2:12 pm

Re: Servo moves "randomly" on initialization of script?

by adafruit_support_bill on Tue Apr 06, 2021 12:55 pm

Hard to say since it is not entirely clear what the source of the problem is. If it is spurious noise, than OE is not going to help. If it is some arbitrary signal going out before you have everything initialized, then you could use OE to suppress the signal output until you knew everything was fully initialized.

adafruit_support_bill
 
Posts: 81604
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.