Due to high demand expect some shipping delays at this time, orders may not ship for 1-2 business days.
0

Magtag display issue
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Magtag display issue

by tj_berlin on Thu Apr 29, 2021 6:42 pm

Dear Adafruit support,

I just received my Magtag via Digikey but unfortunately there is an issue with the display.

There's a vertical line that is constantly displayed (like a pixel error or similar):

IMG_5225.jpg
IMG_5225.jpg (321.76 KiB) Viewed 42 times


IMG_5226.jpg
IMG_5226.jpg (237.27 KiB) Viewed 42 times


I installed the latest version of CircuitPython and tried different demos but the line remains.

In the forum I found a post about a similar issue (https://forums.adafruit.com/viewtopic.php?f=60&t=175037&p=853201&hilit=magtag+display+issue#p853201) with the advice to check the ribbon cable but it looks ok to me as far as I can tell:
IMG_5233.JPG
IMG_5233.JPG (263.4 KiB) Viewed 42 times



Is there anything I can try to fix this or is this a hardware error and getting a replacement is the only way to go?

Thank you very much in advance!

tj_berlin
 
Posts: 2
Joined: Thu Apr 29, 2021 6:14 pm

Re: Magtag display issue

by adafruit_support_carter on Thu Apr 29, 2021 6:54 pm

Hmmm. That ribbon cable looks fine. Thanks for the excellent photos. Let's just replace it. I think that's a pretty low level hardware failure without any easy fix.

Send an email to support@adafruit.com with a link to this thread and they can help get you a replacement MagTag.

adafruit_support_carter
 
Posts: 20130
Joined: Tue Nov 29, 2016 2:45 pm

Re: Magtag display issue

by tj_berlin on Thu Apr 29, 2021 7:39 pm

Thank you very much for your extremly quick and helpful reply, I have sorted it out with Digikey.

tj_berlin
 
Posts: 2
Joined: Thu Apr 29, 2021 6:14 pm

Please be positive and constructive with your questions and comments.