Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.
0

Failed to get response from VC0706
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Failed to get response from VC0706

by JarrydStringy on Wed Jun 02, 2021 12:00 pm

Hi,
I have a TTL Serial Camera connected to a Feather M0 Adalogger setup with Circuit Python. I am getting the following output when running my program:

Traceback (most recent call last):
File "main.py", line 30, in <module>
File "adafruit_vc0706.py", line 114, in __init__
RuntimeError: Failed to get response from VC0706, check wiring!

The code I am using is from page 26 on the guide: https://cdn-learn.adafruit.com/download ... camera.pdf

I know the camera is wired up correctly as I could produce an image through an Arduino Uno and I have followed the wiring for the Feather correctly. Just not sure what this error could be.
Attachments
setup.jpg
setup.jpg (971.68 KiB) Viewed 116 times

JarrydStringy
 
Posts: 2
Joined: Wed Jun 02, 2021 11:44 am

Re: Failed to get response from VC0706

by adafruit_support_carter on Wed Jun 02, 2021 12:12 pm

Try swapping TX/RX connections on one end. Looks like you have TX-TX and RX-RX:
https://learn.adafruit.com/ttl-serial-c ... -3005184-2

adafruit_support_carter
 
Posts: 20354
Joined: Tue Nov 29, 2016 2:45 pm

Re: Failed to get response from VC0706

by JarrydStringy on Wed Jun 02, 2021 12:30 pm

I just got it working. I swapped the TX and RX around, but the problem also seems to also be through the 5V. I swapped from USB to battery and it worked. Thanks for the help.

JarrydStringy
 
Posts: 2
Joined: Wed Jun 02, 2021 11:44 am

Please be positive and constructive with your questions and comments.