Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.
0

Two dead Pico boards
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Two dead Pico boards

by mderousselle on Mon Jun 07, 2021 7:26 am

I have two new Picos. These are my first Picos.
One I soldered the headers on and the other I left in the bag.
I could not get Windows 10 see the first one. I tried two different cables.
The LED does not illuminate.
Then I pulled the other one out of the package and tried it with same results.
I then plugged one of the cables into a Pi Zero, which powered up.

The thing that I have not tried is plugging it into my Pi 4, or, providing it with power apart from the USB interface
Is it possible that I have tow DOA?
Anyone have suggestions?
mderousselle
 
Posts: 3
Joined: Sun Jul 14, 2013 1:11 pm

Re: Two dead Pico boards

by dastels on Mon Jun 07, 2021 9:00 am

The LED isn't a power indicator (there isn't one).

Are your cables (well, one of them at least) data or just power/charge? That's the first thing to check.

What happens if you hold BOOTSEL down while connecting or resetting? Specifically, a drive named RPI-RP2 should mount.

Have you read through (and followed the instructions) https://learn.adafruit.com/getting-started-with-raspberry-pi-pico-circuitpython.

There's also official arduino support, if you're interested: https://www.tomshardware.com/news/raspberry-pi-pico-arduino-official

Dave

dastels
 
Posts: 6475
Joined: Tue Oct 20, 2015 3:22 pm

Re: Two dead Pico boards

by mderousselle on Mon Jun 07, 2021 9:49 am

I will purchase an Android data/charging cord, to rule out the cable problem.
RPI-RP2 never mounts.
I will follow up when I receive the cables tomorrow.
mderousselle
 
Posts: 3
Joined: Sun Jul 14, 2013 1:11 pm

Re: Two dead Pico boards

by mderousselle on Tue Jun 08, 2021 8:14 am

I plugged in a USB cable straight to my laptop and this time, I unplugged the dock from my laptop and it now sees the Pico. I believe that I have the cause narrowed down to a charging cable for my keyboard.
mderousselle
 
Posts: 3
Joined: Sun Jul 14, 2013 1:11 pm

Re: Two dead Pico boards

by dastels on Tue Jun 08, 2021 9:03 am

Excellent!

Dave

dastels
 
Posts: 6475
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.