0

Arduino support for Itsy Bitsy M0 Express?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Arduino support for Itsy Bitsy M0 Express?

by jmaloney on Fri Apr 27, 2018 8:47 am

I'm using the Arduino IDE 1.8.2 with the "Arduino SAMD" board package version 1.6.18 (latest). That package includes an entry for the AdaFruit Circuit Playground Express but not for any other AdaFruit M0 boards. Is there another board package I should install?

I have been able to program the Itsy Bitsy M0 Express using the "Circuit Playground Express" board definition, so maybe that's the best solution. Does the pin numbering in that board definition match the Itsy Bitsy M0 Express? Any discrepancies I need to know about?

jmaloney
 
Posts: 46
Joined: Fri Apr 27, 2018 8:33 am

Re: Arduino support for Itsy Bitsy M0 Express?

by danhalbert on Fri Apr 27, 2018 9:39 am

You need to install the Adafruit SAMD package as well, which becomes visible when you add a URL to the Arduino preferences. Then there will be a specific entry for the Itsy Bitsy M0. Follow the directions here to setup Arduino:
https://learn.adafruit.com/adafruit-fea ... -ide-setup
You may want to upgrade to Arduino 1.8.5, the latest one.

The pins are not the same. They are closest to the Itsy Bitsy 32u4. We haven't yet finished the Itsy Bitsy M0 guide -- sorry!

danhalbert
 
Posts: 2494
Joined: Tue Aug 08, 2017 12:37 pm

Re: Arduino support for Itsy Bitsy M0 Express?

by jmaloney on Fri Apr 27, 2018 9:47 am

Perfect! I was hoping that there was a specific board definition for that board.

Thank you for the very quick response.

jmaloney
 
Posts: 46
Joined: Fri Apr 27, 2018 8:33 am

Please be positive and constructive with your questions and comments.